aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2019-05-14 13:13:53 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2019-05-14 13:15:11 +0200
commit3611cfe73d5f9680d387ef14632431fac30bbd9b (patch)
treef419e735918c6ff0c9b78138ddf553ba11632e97 /target/linux/brcm63xx
parent86fd8cb435daf05f52468daabd41a363917485b7 (diff)
downloadupstream-3611cfe73d5f9680d387ef14632431fac30bbd9b.tar.gz
upstream-3611cfe73d5f9680d387ef14632431fac30bbd9b.tar.bz2
upstream-3611cfe73d5f9680d387ef14632431fac30bbd9b.zip
brcm63xx: fixup broken patch after kernel bump
Fixes the following compilation issue that was introduced with the bump to 4.14.118: CC drivers/gpio/gpiolib-of.o drivers/gpio/gpiolib-of.c: In function 'of_gpiochip_add': drivers/gpio/gpiolib-of.c:510:12: error: too few arguments to function 'of_gpiochip_scan_gpios' status = of_gpiochip_scan_gpios(chip); ^~~~~~~~~~~~~~~~~~~~~~ drivers/gpio/gpiolib-of.c:247:5: note: declared here int of_gpiochip_scan_gpios(struct gpio_chip *chip, unsigned int start, ^~~~~~~~~~~~~~~~~~~~~~ scripts/Makefile.build:326: recipe for target 'drivers/gpio/gpiolib-of.o' failed Fixes: 09050b6fe228 ("kernel: bump 4.14 to 4.14.118") Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch b/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
index 61e1b282c7..a42c894549 100644
--- a/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
+++ b/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
@@ -77,7 +77,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
- of_node_put(chip->of_node);
- gpiochip_remove_pin_ranges(chip);
+ if (!chip->request) {
-+ status = of_gpiochip_scan_gpios(chip);
++ status = of_gpiochip_scan_gpios(chip, 0, chip->ngpio);
+ if (status) {
+ of_node_put(chip->of_node);
+ gpiochip_remove_pin_ranges(chip);