aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-18 21:50:37 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-18 21:50:37 +0000
commit84ea696e031eb88f1f57700f24ca315fb2a3372c (patch)
tree786b1ae366bcb2980ba27a32efc8563084228fe1 /target/linux/brcm63xx/profiles
parent4e708346cd4dfb5720170904e47ff960803e6889 (diff)
downloadupstream-84ea696e031eb88f1f57700f24ca315fb2a3372c.tar.gz
upstream-84ea696e031eb88f1f57700f24ca315fb2a3372c.tar.bz2
upstream-84ea696e031eb88f1f57700f24ca315fb2a3372c.zip
brcm63xx: move generic profiles to top dir and remove smp profiles
Use generic profiles for brcm63xx instead of having similar profiles for each subtarget. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42208
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/100-Broadcom.mk17
-rw-r--r--target/linux/brcm63xx/profiles/101-Broadcom-wl.mk19
-rw-r--r--target/linux/brcm63xx/profiles/102-Atheros.mk17
-rw-r--r--target/linux/brcm63xx/profiles/103-Ralink.mk13
-rw-r--r--target/linux/brcm63xx/profiles/104-No-WiFi.mk17
-rw-r--r--target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk17
-rw-r--r--target/linux/brcm63xx/profiles/200-GW6X00.mk20
-rw-r--r--target/linux/brcm63xx/profiles/201-Huawei.mk26
-rw-r--r--target/linux/brcm63xx/profiles/202-Sagemcom.mk16
9 files changed, 162 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/100-Broadcom.mk b/target/linux/brcm63xx/profiles/100-Broadcom.mk
new file mode 100644
index 0000000000..bc68f14937
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/100-Broadcom.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom WiFi (default)
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+
+define Profile/Broadcom/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..4f2d605eb7
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+ PACKAGES:= kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware using Broadcom BCM43xx cards
+ using the proprietary broadcom wireless "wl" driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm63xx/profiles/102-Atheros.mk b/target/linux/brcm63xx/profiles/102-Atheros.mk
new file mode 100644
index 0000000000..b214185c5d
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/102-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-ath5k kmod-ath9k wpad-mini
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm63xx/profiles/103-Ralink.mk b/target/linux/brcm63xx/profiles/103-Ralink.mk
new file mode 100644
index 0000000000..412c5a45ad
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/103-Ralink.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+ NAME:=Ralink WiFi
+ PACKAGES:=kmod-rt61-pci wpad-mini
+endef
+$(eval $(call Profile,Ralink))
+
diff --git a/target/linux/brcm63xx/profiles/104-No-WiFi.mk b/target/linux/brcm63xx/profiles/104-No-WiFi.mk
new file mode 100644
index 0000000000..9b59b172fe
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/104-No-WiFi.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NoWiFi
+ NAME:=No WiFi (BCM6338)
+ PACKAGES:=
+endef
+
+define Profile/NoWiFi/description
+ Package set compatible with BCM63xx routers without Wi-Fi (e.g: BCM6338-based).
+endef
+
+$(eval $(call Profile,NoWiFi))
diff --git a/target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk b/target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk
new file mode 100644
index 0000000000..bb558d1390
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-brcmsmac
+ NAME:=Broadcom WiFi (brcmsmac)
+ PACKAGES:=kmod-brcmsmac wpad-mini
+endef
+
+define Profile/Broadcom-brcmsmac/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom-brcmsmac))
+
diff --git a/target/linux/brcm63xx/profiles/200-GW6X00.mk b/target/linux/brcm63xx/profiles/200-GW6X00.mk
new file mode 100644
index 0000000000..1cb763dac1
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/200-GW6X00.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/GW6X00
+ NAME:=Tecom GW6X00
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb-storage \
+ kmod-fs-ext4 kmod-nls-cp437 kmod-nls-iso8859-1 e2fsprogs \
+ kmod-ipt-nathelper-extra wlc
+endef
+
+define Profile/GW6X00/Description
+ Package set compatible with the Tecom GW6000 and GW6200 based
+ on the BCM96348GW reference design.
+endef
+$(eval $(call Profile,GW6X00))
+
diff --git a/target/linux/brcm63xx/profiles/201-Huawei.mk b/target/linux/brcm63xx/profiles/201-Huawei.mk
new file mode 100644
index 0000000000..820f5e096c
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/201-Huawei.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2012-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HW553
+ NAME:=Huawei HG553
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HW553/Description
+ Package set optimized for Huawei HG553 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,HW553))
+
+define Profile/HW556
+ NAME:=Huawei HG556a
+ PACKAGES:=kmod-rt2800-pci kmod-ath9k wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HW556/Description
+ Package set optimized for Huawei HG556a using open-source atheros or ralink WiFi driver
+endef
+$(eval $(call Profile,HW556))
diff --git a/target/linux/brcm63xx/profiles/202-Sagemcom.mk b/target/linux/brcm63xx/profiles/202-Sagemcom.mk
new file mode 100644
index 0000000000..ebe1755f09
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/202-Sagemcom.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sagemcom-2704V2
+ NAME:=Sagemcom F@ST 2704 V2
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/Sagemcom-2704V2/Description
+ Package set optimized for Sagemcom F@ST 2704 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,Sagemcom-2704V2))