aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:35:12 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:35:12 +0000
commit2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f (patch)
tree0d96527eccb0e68a4bddf9cf90cc07c5a057f4b4 /target/linux/brcm63xx/image
parent065d6e9047d235ffa916dcf0ce330bfc124e2fd0 (diff)
downloadupstream-2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f.tar.gz
upstream-2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f.tar.bz2
upstream-2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f.zip
brcm63xx: Add BT Home Hub 2A support.
Support for the BT HomeHub 2.0 Type A. This router was manufactured by Thomson, and it's BCM6358 based. The leds are controled by two chained HC594, all working ok. The BCM5325 switch has the RESET# pin wired to the GPIO15, but currently there is no way to tell the b53 driver how to get this gpio number in brcm63xx, therefore swconfig won't use it when performing a switch reset. The patch was tested with several firmwares, and all except unsupported stuff (i.e xDSL) works pretty well. Tested-by: Tahir <tahir00ali@gmail.com> Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> SVN-Revision: 44985
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index a55fc46d6c..bae025f7d2 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -275,6 +275,8 @@ $(eval $(call ImageDTB,CFEDTB,RG100A,RG100A,rg100a,96358VW2,6358,--block-size 0x
$(eval $(call ImageDTB,CFEDTB,AR1004G,AR1004G,ar1004g,96348GW-10,6348))
# Belkin F5D7633
$(eval $(call ImageDTB,CFEDTB,F5D7633,F5D7633,f5d7633,96348GW-10,6348,--block-size 0x20000 --image-offset 0x20000))
+# BT Home Hub 2.0 A
+$(eval $(call ImageDTB,CFEDTB,BTHOMEHUB2A,HomeHub2A,homehub2a,HOMEHUB2A,6358,--image-offset 0x20000 --block-size 0x20000))
# BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
$(eval $(call ImageDTB,CFEDTB,BTV2500V,BTV2500V,v2500v-bb,V2500V_BB,6348,--layoutver 5))
# Comtrend AR-5381u