aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-07-17 10:54:08 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-07-17 10:54:08 +0000
commit0d2746eb209f0382b0f40ba83f17ad359d5869e0 (patch)
treede7e1d27641dbb676a5c7139b6a500d9a53c1005 /target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch
parentbec5f22912a0a662f039442f977c814ed20226ca (diff)
downloadupstream-0d2746eb209f0382b0f40ba83f17ad359d5869e0.tar.gz
upstream-0d2746eb209f0382b0f40ba83f17ad359d5869e0.tar.bz2
upstream-0d2746eb209f0382b0f40ba83f17ad359d5869e0.zip
bump brcm63xx to 2.6.22.1, too
SVN-Revision: 8018
Diffstat (limited to 'target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch')
-rw-r--r--target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch b/target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch
index 82a2c94059..08c91bea1b 100644
--- a/target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch
+++ b/target/linux/brcm63xx-2.6/patches/040-bcm963xx_flashmap.patch
@@ -1,7 +1,7 @@
diff -urN linux-2.6.19/drivers/mtd/maps/Kconfig linux-2.6.19.new/drivers/mtd/maps/Kconfig
--- linux-2.6.19/drivers/mtd/maps/Kconfig 2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.new/drivers/mtd/maps/Kconfig 2006-12-18 17:21:07.000000000 +0100
-@@ -224,6 +224,13 @@
+@@ -283,6 +283,13 @@
Flash memory access on 4G Systems MTX-1 Board. If you have one of
these boards and would like to use the flash chips on it, say 'Y'.
@@ -18,7 +18,7 @@ diff -urN linux-2.6.19/drivers/mtd/maps/Kconfig linux-2.6.19.new/drivers/mtd/map
diff -urN linux-2.6.19/drivers/mtd/maps/Makefile linux-2.6.19.new/drivers/mtd/maps/Makefile
--- linux-2.6.19/drivers/mtd/maps/Makefile 2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.new/drivers/mtd/maps/Makefile 2006-12-18 17:21:07.000000000 +0100
-@@ -70,3 +70,4 @@
+@@ -72,3 +72,4 @@
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
obj-$(CONFIG_MTD_TQM834x) += tqm834x.o
@@ -35,7 +35,7 @@ diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboo
struct mtd_partition **pparts,
unsigned long fis_origin)
{
-@@ -132,6 +132,14 @@
+@@ -146,6 +146,14 @@
goto out;
}
@@ -50,7 +50,7 @@ diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboo
for (i = 0; i < numslots; i++) {
struct fis_list *new_fl, **prev;
-@@ -154,9 +162,8 @@
+@@ -168,9 +176,8 @@
new_fl->img = &buf[i];
if (fis_origin) {
buf[i].flash_base -= fis_origin;