aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:11:49 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:11:49 +0000
commitbf64ac730a89359abdbb5d9aef99a0ba5a1fc4a4 (patch)
treea1c3c78c2478a365a346ceee980e8347c2b686a9 /target/linux/brcm47xx
parente04f68fb77365b724435163134890ea4583e28ab (diff)
downloadupstream-bf64ac730a89359abdbb5d9aef99a0ba5a1fc4a4.tar.gz
upstream-bf64ac730a89359abdbb5d9aef99a0ba5a1fc4a4.tar.bz2
upstream-bf64ac730a89359abdbb5d9aef99a0ba5a1fc4a4.zip
bcm47xx: Remove kernel checks from image Makefile
2.4 isn't present anymore, so it will always be 2.6 (or newer). Since the 2.6 check will break with 3.0, remove it alltogether. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 27185
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 034200c50a..bda42290c1 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -24,12 +24,10 @@ define Image/Prepare
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
-ifneq ($(KERNEL),2.4)
- define Image/Build/wgt634u
+define Image/Build/wgt634u
dd if=$(KDIR)/loader.elf of=$(BIN_DIR)/openwrt-wgt634u-$(2).bin bs=131072 conv=sync
cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/openwrt-wgt634u-$(2).bin
- endef
-endif
+endef
define Image/Build/CyberTAN
$(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -o $(BIN_DIR)/openwrt-$(2)-$(5).bin $(if $(6),-s $(6))
@@ -75,9 +73,7 @@ define Image/Build/jffs2-128k
$(call Image/Build/CyberTAN,$(1),wrt54gs,W54S,4.80.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/CyberTAN,$(1),wrtsl54gs,W54U,2.08.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/trxV2,$(1),wrt54g3gv2-vf,3G2V,3.00.24,$(patsubst jffs2-%,jffs2,$(1)),6)
- ifeq ($(KERNEL),2.6)
$(call Image/Build/wgt634u,$(1),$(patsubst jffs2-%,jffs2,$(1)))
- endif
endef
define Image/Build/jffs2-64k