aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2017-12-27 08:55:28 +0100
committerRafał Miłecki <rafal@milecki.pl>2017-12-29 23:18:19 +0100
commit612a93564ce24d05c039669f50b64cfad1cdffde (patch)
tree23345c576c322bb2619b93544a721dff61c8634f /target/linux/brcm47xx
parentfea884ff51cc2ed1016b4e13a9fcc728bd4f357e (diff)
downloadupstream-612a93564ce24d05c039669f50b64cfad1cdffde.tar.gz
upstream-612a93564ce24d05c039669f50b64cfad1cdffde.tar.bz2
upstream-612a93564ce24d05c039669f50b64cfad1cdffde.zip
brcm47xx: image: build firmware for Asus WL-500g Deluxe
It's a device based on BCM5365P (0x5365 package 0x00). This SoC has USB 1.1 controller but device has two USB 2.0 parts. They are handled by PCI-based controllers: 1106:3038 UHCI and 1106:3104 EHCI. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 284e1f7c05..47f031b8b4 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -282,6 +282,14 @@ define Device/asus-wl-330ge
endef
TARGET_DEVICES += asus-wl-330ge
+define Device/asus-wl-500gd
+ DEVICE_TITLE := Asus WL-500g Deluxe
+ DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
+ $(Device/asus)
+ PRODUCTID := "WL500gx "
+endef
+TARGET_DEVICES += asus-wl-500gd
+
define Device/asus-wl-500gp-v1
DEVICE_TITLE := Asus WL-500gP v1
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)