aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/mips74k
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-07-10 19:22:41 +0200
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-10-16 15:07:41 +0100
commit80c61c161ac5943137ade233d62cf89d746de5a2 (patch)
treef6260a84b8d5696e645f59e6b68b9a2c21c4824a /target/linux/brcm47xx/mips74k
parent1063d904b78297b3e21a352bed19bd312235ff65 (diff)
downloadupstream-80c61c161ac5943137ade233d62cf89d746de5a2.tar.gz
upstream-80c61c161ac5943137ade233d62cf89d746de5a2.tar.bz2
upstream-80c61c161ac5943137ade233d62cf89d746de5a2.zip
treewide: use wpad-basic for not small flash targets
Add out of the box support for 802.11r and 802.11w to all targets not suffering from small flash. Signed-off-by: Mathias Kresin <dev@kresin.me> Mathias did all the heavy lifting on this, but I'm the one who should get shouted at for committing. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'target/linux/brcm47xx/mips74k')
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk2
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk2
-rw-r--r--target/linux/brcm47xx/mips74k/target.mk2
3 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
index 502fff462d..66b13bf879 100644
--- a/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
+++ b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
@@ -7,7 +7,7 @@
define Profile/Broadcom-mips74k-wl
NAME:=Broadcom SoC, BCM43xx WiFi (proprietary wl)
- PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+ PACKAGES:=-wpad-basic kmod-brcm-wl wlc nas
endef
define Profile/Broadcom-mips74k-wl/Description
diff --git a/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
index 5790527780..cc4668de52 100644
--- a/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
+++ b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
@@ -7,7 +7,7 @@
define Profile/Broadcom-mips74k-none
NAME:=Broadcom SoC, No WiFi
- PACKAGES:=-wpad-mini
+ PACKAGES:=-wpad-basic
endef
define Profile/Broadcom-mips74k-none/Description
diff --git a/target/linux/brcm47xx/mips74k/target.mk b/target/linux/brcm47xx/mips74k/target.mk
index e5c2565258..1e2e8436d5 100644
--- a/target/linux/brcm47xx/mips74k/target.mk
+++ b/target/linux/brcm47xx/mips74k/target.mk
@@ -1,6 +1,8 @@
BOARDNAME:=MIPS 74K
CPU_TYPE:=74kc
+DEFAULT_PACKAGES += wpad-basic
+
define Target/Description
Build firmware for Broadcom BCM47xx and BCM53xx devices with
MIPS 74K CPU.