aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-10-28 16:39:08 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-10-28 16:41:05 +0200
commit8bd21672364e44cecebb8aef27041e6c607addaa (patch)
treeab048ff71e69a0862244381ff7a29b4120217019 /target/linux/brcm47xx/image/Makefile
parentc9fdb23345121c0de1af5fe705cc245e45c862d5 (diff)
downloadupstream-8bd21672364e44cecebb8aef27041e6c607addaa.tar.gz
upstream-8bd21672364e44cecebb8aef27041e6c607addaa.tar.bz2
upstream-8bd21672364e44cecebb8aef27041e6c607addaa.zip
brcm47xx: image: make linksys-pattern-partition leave specific file
Thanks to leaving .pattern file we can easily insert extra step between linksys-pattern-partition and trx-v2-with-loader, e.g. rootfs one. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/brcm47xx/image/Makefile')
-rw-r--r--target/linux/brcm47xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 5d8e6ff7d5..84e70051a4 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -64,7 +64,7 @@ define Build/trx-v2-with-loader
-o $@.new \
-f $(KDIR)/loader.gz \
-f $(KDIR)/vmlinux.lzma \
- $(call trxalign/$(FILESYSTEM),$(FILESYSTEM),$@)
+ $(call trxalign/$(FILESYSTEM),$(FILESYSTEM),$@.pattern)
mv $@.new $@
endef
@@ -99,7 +99,7 @@ define Build/linksys-bin
endef
define Build/linksys-pattern-partition
- $(STAGING_DIR_HOST)/bin/addpattern -5 -p $(DEVICE_ID) -v v$(VERSION) $(if $(SERIAL),-s $(SERIAL)) -i /dev/null -o $@
+ $(STAGING_DIR_HOST)/bin/addpattern -5 -p $(DEVICE_ID) -v v$(VERSION) $(if $(SERIAL),-s $(SERIAL)) -i /dev/null -o $@.pattern
endef
define Build/motorola-bin