aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2017-03-04 19:37:50 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2017-03-04 19:37:50 +0100
commitbaad22eed3ea3242051bbde6ebf56e74deb11ea6 (patch)
tree2980f26a82772c37d7d655871780fad0f3a4aeb1 /target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch
parentf229f4af31731badc2dec27c9bdef9f5fa8f7433 (diff)
downloadupstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.tar.gz
upstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.tar.bz2
upstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.zip
brcm2708: update linux 4.9 patches to latest version
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch')
-rw-r--r--target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch b/target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch
deleted file mode 100644
index 946c316bc1..0000000000
--- a/target/linux/brcm2708/patches-4.9/0110-i2c-bcm2835-Can-t-support-I2C_M_IGNORE_NAK.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 9d8c576116c4818dd745ff112504f0fdf78c9e1e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Noralf=20Tr=C3=B8nnes?= <noralf@tronnes.org>
-Date: Thu, 22 Sep 2016 22:05:50 +0200
-Subject: [PATCH] i2c: bcm2835: Can't support I2C_M_IGNORE_NAK
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The controller can't support this flag, so remove it.
-
-Documentation/i2c/i2c-protocol states that all of the message is sent:
-
-I2C_M_IGNORE_NAK:
- Normally message is interrupted immediately if there is [NA] from the
- client. Setting this flag treats any [NA] as [A], and all of
- message is sent.
-
-From the BCM2835 ARM Peripherals datasheet:
-
- The ERR field is set when the slave fails to acknowledge either
- its address or a data byte written to it.
-
-So when the controller doesn't receive an ack, it sets ERR and raises
-an interrupt. In other words, the whole message is not sent.
-
-Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
-Reviewed-by: Eric Anholt <eric@anholt.net>
----
- drivers/i2c/busses/i2c-bcm2835.c | 4 ----
- 1 file changed, 4 deletions(-)
-
---- a/drivers/i2c/busses/i2c-bcm2835.c
-+++ b/drivers/i2c/busses/i2c-bcm2835.c
-@@ -212,10 +212,6 @@ static int bcm2835_i2c_xfer_msg(struct b
- if (likely(!i2c_dev->msg_err))
- return 0;
-
-- if ((i2c_dev->msg_err & BCM2835_I2C_S_ERR) &&
-- (msg->flags & I2C_M_IGNORE_NAK))
-- return 0;
--
- dev_dbg(i2c_dev->dev, "i2c transfer failed: %x\n", i2c_dev->msg_err);
-
- if (i2c_dev->msg_err & BCM2835_I2C_S_ERR)