aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2017-03-04 19:37:50 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2017-03-04 19:37:50 +0100
commitbaad22eed3ea3242051bbde6ebf56e74deb11ea6 (patch)
tree2980f26a82772c37d7d655871780fad0f3a4aeb1 /target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch
parentf229f4af31731badc2dec27c9bdef9f5fa8f7433 (diff)
downloadupstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.tar.gz
upstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.tar.bz2
upstream-baad22eed3ea3242051bbde6ebf56e74deb11ea6.zip
brcm2708: update linux 4.9 patches to latest version
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.9.y - Remove led1 from diag.sh for RPi3 since it causes boot issues. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch')
-rw-r--r--target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch b/target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch
deleted file mode 100644
index 5dc6f85e95..0000000000
--- a/target/linux/brcm2708/patches-4.9/0104-raspberrypi-firmware-Export-the-general-transaction-.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 207c380da679f31a62a1bb604dd22834d902acaf Mon Sep 17 00:00:00 2001
-From: Eric Anholt <eric@anholt.net>
-Date: Wed, 14 Sep 2016 09:16:19 +0100
-Subject: [PATCH] raspberrypi-firmware: Export the general transaction
- function.
-
-The vc4-firmware-kms module is going to be doing the MBOX FB call.
-
-Signed-off-by: Eric Anholt <eric@anholt.net>
----
- drivers/firmware/raspberrypi.c | 3 ++-
- include/soc/bcm2835/raspberrypi-firmware.h | 1 +
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
---- a/drivers/firmware/raspberrypi.c
-+++ b/drivers/firmware/raspberrypi.c
-@@ -42,7 +42,7 @@ static void response_callback(struct mbo
- * Sends a request to the firmware through the BCM2835 mailbox driver,
- * and synchronously waits for the reply.
- */
--static int
-+int
- rpi_firmware_transaction(struct rpi_firmware *fw, u32 chan, u32 data)
- {
- u32 message = MBOX_MSG(chan, data);
-@@ -63,6 +63,7 @@ rpi_firmware_transaction(struct rpi_firm
-
- return ret;
- }
-+EXPORT_SYMBOL_GPL(rpi_firmware_transaction);
-
- /**
- * rpi_firmware_property_list - Submit firmware property list
---- a/include/soc/bcm2835/raspberrypi-firmware.h
-+++ b/include/soc/bcm2835/raspberrypi-firmware.h
-@@ -131,5 +131,6 @@ int rpi_firmware_property(struct rpi_fir
- int rpi_firmware_property_list(struct rpi_firmware *fw,
- void *data, size_t tag_size);
- struct rpi_firmware *rpi_firmware_get(struct device_node *firmware_node);
-+int rpi_firmware_transaction(struct rpi_firmware *fw, u32 chan, u32 data);
-
- #endif /* __SOC_RASPBERRY_FIRMWARE_H__ */