aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2019-08-02 18:55:55 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2019-08-02 18:55:55 +0200
commit00813d4dd976cc823fa089840ff2f4a10dd6cd0c (patch)
tree8f2c74a928c9ea0eceb64809d9039db824ae6663 /target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
parent19226502bf6393706defe7f049c587b32c9b4f33 (diff)
downloadupstream-00813d4dd976cc823fa089840ff2f4a10dd6cd0c.tar.gz
upstream-00813d4dd976cc823fa089840ff2f4a10dd6cd0c.tar.bz2
upstream-00813d4dd976cc823fa089840ff2f4a10dd6cd0c.zip
brcm2708: remove linux 4.14 support
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch')
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch202
1 files changed, 0 insertions, 202 deletions
diff --git a/target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch b/target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
deleted file mode 100644
index cf461bb14c..0000000000
--- a/target/linux/brcm2708/patches-4.14/950-0079-Allo-Piano-DAC-boards-Initial-2-channel-stereo-suppo.patch
+++ /dev/null
@@ -1,202 +0,0 @@
-From 661bd422e6881e357a9e267548e446bdff71a797 Mon Sep 17 00:00:00 2001
-From: Clive Messer <clive.m.messer@gmail.com>
-Date: Mon, 19 Sep 2016 14:01:04 +0100
-Subject: [PATCH 079/454] Allo Piano DAC boards: Initial 2 channel (stereo)
- support (#1645)
-
-Add initial 2 channel (stereo) support for Allo Piano DAC (2.0/2.1) boards,
-using allo-piano-dac-pcm512x-audio overlay and allo-piano-dac ALSA ASoC
-machine driver.
-
-NB. The initial support is 2 channel (stereo) ONLY!
-(The Piano DAC 2.1 will only support 2 channel (stereo) left/right output,
- pending an update to the upstream pcm512x codec driver, which will have
- to be submitted via upstream. With the initial downstream support,
- provided by this patch, the Piano DAC 2.1 subwoofer outputs will
- not function.)
-
-Signed-off-by: Baswaraj K <jaikumar@cem-solutions.net>
-Signed-off-by: Clive Messer <clive.messer@digitaldreamtime.co.uk>
-Tested-by: Clive Messer <clive.messer@digitaldreamtime.co.uk>
----
- sound/soc/bcm/Kconfig | 7 ++
- sound/soc/bcm/Makefile | 2 +
- sound/soc/bcm/allo-piano-dac.c | 144 +++++++++++++++++++++++++++++++++
- 3 files changed, 153 insertions(+)
- create mode 100644 sound/soc/bcm/allo-piano-dac.c
-
---- a/sound/soc/bcm/Kconfig
-+++ b/sound/soc/bcm/Kconfig
-@@ -124,3 +124,10 @@ config SND_BCM2708_SOC_DIONAUDIO_LOCO
- select SND_SOC_PCM5102a
- help
- Say Y or M if you want to add support for Dion Audio LOCO.
-+
-+config SND_BCM2708_SOC_ALLO_PIANO_DAC
-+ tristate "Support for Allo Piano DAC"
-+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
-+ select SND_SOC_PCM512x_I2C
-+ help
-+ Say Y or M if you want to add support for Allo Piano DAC.
---- a/sound/soc/bcm/Makefile
-+++ b/sound/soc/bcm/Makefile
-@@ -24,6 +24,7 @@ snd-soc-raspidac3-objs := raspidac3.o
- snd-soc-audioinjector-pi-soundcard-objs := audioinjector-pi-soundcard.o
- snd-soc-digidac1-soundcard-objs := digidac1-soundcard.o
- snd-soc-dionaudio-loco-objs := dionaudio_loco.o
-+snd-soc-allo-piano-dac-objs := allo-piano-dac.o
-
- obj-$(CONFIG_SND_BCM2708_SOC_ADAU1977_ADC) += snd-soc-adau1977-adc.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_AMP) += snd-soc-hifiberry-amp.o
-@@ -40,3 +41,4 @@ obj-$(CONFIG_SND_BCM2708_SOC_RASPIDAC3)
- obj-$(CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD) += snd-soc-audioinjector-pi-soundcard.o
- obj-$(CONFIG_SND_DIGIDAC1_SOUNDCARD) += snd-soc-digidac1-soundcard.o
- obj-$(CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO) += snd-soc-dionaudio-loco.o
-+obj-$(CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC) += snd-soc-allo-piano-dac.o
---- /dev/null
-+++ b/sound/soc/bcm/allo-piano-dac.c
-@@ -0,0 +1,144 @@
-+/*
-+ * ALSA ASoC Machine Driver for Allo Piano DAC
-+ *
-+ * Author: Baswaraj K <jaikumar@cem-solutions.net>
-+ * Copyright 2016
-+ * based on code by Daniel Matuschek <info@crazy-audio.com>
-+ * based on code by Florian Meier <florian.meier@koalo.de>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/pcm_params.h>
-+#include <sound/soc.h>
-+
-+static bool digital_gain_0db_limit = true;
-+
-+static int snd_allo_piano_dac_init(struct snd_soc_pcm_runtime *rtd)
-+{
-+ if (digital_gain_0db_limit) {
-+ int ret;
-+ struct snd_soc_card *card = rtd->card;
-+
-+ ret = snd_soc_limit_volume(card, "Digital Playback Volume",
-+ 207);
-+ if (ret < 0)
-+ dev_warn(card->dev, "Failed to set volume limit: %d\n",
-+ ret);
-+ }
-+
-+ return 0;
-+}
-+
-+static int snd_allo_piano_dac_hw_params(
-+ struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
-+{
-+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
-+
-+ unsigned int sample_bits =
-+ snd_pcm_format_physical_width(params_format(params));
-+
-+ return snd_soc_dai_set_bclk_ratio(cpu_dai, sample_bits * 2);
-+}
-+
-+/* machine stream operations */
-+static struct snd_soc_ops snd_allo_piano_dac_ops = {
-+ .hw_params = snd_allo_piano_dac_hw_params,
-+};
-+
-+static struct snd_soc_dai_link snd_allo_piano_dac_dai[] = {
-+{
-+ .name = "Piano DAC",
-+ .stream_name = "Piano DAC HiFi",
-+ .cpu_dai_name = "bcm2708-i2s.0",
-+ .codec_dai_name = "pcm512x-hifi",
-+ .platform_name = "bcm2708-i2s.0",
-+ .codec_name = "pcm512x.1-004c",
-+ .dai_fmt = SND_SOC_DAIFMT_I2S |
-+ SND_SOC_DAIFMT_NB_NF |
-+ SND_SOC_DAIFMT_CBS_CFS,
-+ .ops = &snd_allo_piano_dac_ops,
-+ .init = snd_allo_piano_dac_init,
-+},
-+};
-+
-+/* audio machine driver */
-+static struct snd_soc_card snd_allo_piano_dac = {
-+ .name = "PianoDAC",
-+ .owner = THIS_MODULE,
-+ .dai_link = snd_allo_piano_dac_dai,
-+ .num_links = ARRAY_SIZE(snd_allo_piano_dac_dai),
-+};
-+
-+static int snd_allo_piano_dac_probe(struct platform_device *pdev)
-+{
-+ int ret = 0;
-+
-+ snd_allo_piano_dac.dev = &pdev->dev;
-+
-+ if (pdev->dev.of_node) {
-+ struct device_node *i2s_node;
-+ struct snd_soc_dai_link *dai;
-+
-+ dai = &snd_allo_piano_dac_dai[0];
-+ i2s_node = of_parse_phandle(pdev->dev.of_node,
-+ "i2s-controller", 0);
-+
-+ if (i2s_node) {
-+ dai->cpu_dai_name = NULL;
-+ dai->cpu_of_node = i2s_node;
-+ dai->platform_name = NULL;
-+ dai->platform_of_node = i2s_node;
-+ }
-+
-+ digital_gain_0db_limit = !of_property_read_bool(
-+ pdev->dev.of_node, "allo,24db_digital_gain");
-+ }
-+
-+ ret = snd_soc_register_card(&snd_allo_piano_dac);
-+ if (ret && ret != -EPROBE_DEFER)
-+ dev_err(&pdev->dev,
-+ "snd_soc_register_card() failed: %d\n", ret);
-+
-+ return ret;
-+}
-+
-+static int snd_allo_piano_dac_remove(struct platform_device *pdev)
-+{
-+ return snd_soc_unregister_card(&snd_allo_piano_dac);
-+}
-+
-+static const struct of_device_id snd_allo_piano_dac_of_match[] = {
-+ { .compatible = "allo,piano-dac", },
-+ { /* sentinel */ },
-+};
-+MODULE_DEVICE_TABLE(of, snd_allo_piano_dac_of_match);
-+
-+static struct platform_driver snd_allo_piano_dac_driver = {
-+ .driver = {
-+ .name = "snd-allo-piano-dac",
-+ .owner = THIS_MODULE,
-+ .of_match_table = snd_allo_piano_dac_of_match,
-+ },
-+ .probe = snd_allo_piano_dac_probe,
-+ .remove = snd_allo_piano_dac_remove,
-+};
-+
-+module_platform_driver(snd_allo_piano_dac_driver);
-+
-+MODULE_AUTHOR("Baswaraj K <jaikumar@cem-solutions.net>");
-+MODULE_DESCRIPTION("ALSA ASoC Machine Driver for Allo Piano DAC");
-+MODULE_LICENSE("GPL v2");