aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-07-24 20:39:17 +0000
committerJohn Crispin <john@openwrt.org>2012-07-24 20:39:17 +0000
commit0e9e7dcd10c4f0653252076ccc4289cfcf55c4b4 (patch)
treefe70556f494b2d1d5e055d43a38735f073a5f608 /target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
parent25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472 (diff)
downloadupstream-0e9e7dcd10c4f0653252076ccc4289cfcf55c4b4.tar.gz
upstream-0e9e7dcd10c4f0653252076ccc4289cfcf55c4b4.tar.bz2
upstream-0e9e7dcd10c4f0653252076ccc4289cfcf55c4b4.zip
adds target used by rapsberry pi
Add support for Raspberry Pi / brcm2708 / 2835 Signed-off-by: Ian Ridge <ianridge [at] gmail.com> SVN-Revision: 32825
Diffstat (limited to 'target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch')
-rw-r--r--target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch b/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
new file mode 100644
index 0000000000..82b6e067c6
--- /dev/null
+++ b/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/lib/Makefile
++++ b/arch/arm/lib/Makefile
+@@ -14,7 +14,7 @@ lib-y := backtrace.o changebit.o csumip
+ ashldi3.o ashrdi3.o lshrdi3.o muldi3.o \
+ ucmpdi2.o lib1funcs.o div64.o \
+ io-readsb.o io-writesb.o io-readsl.o io-writesl.o \
+- call_with_stack.o
++ call_with_stack.o divdi3.o
+
+ mmu-y := clear_user.o copy_page.o getuser.o putuser.o
+