aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-03-27 19:42:18 +0200
committerJohn Crispin <john@phrozen.org>2018-05-24 17:24:30 +0200
commitfff02093e602f7c49161746305a4b13c1a2bb441 (patch)
treee86b2638371017b72204090b5aa4d317d2c326e3 /target/linux/brcm2708/image
parentefdfb253d84a853a3f3efda6b11e958cf5f197ee (diff)
downloadupstream-fff02093e602f7c49161746305a4b13c1a2bb441.tar.gz
upstream-fff02093e602f7c49161746305a4b13c1a2bb441.tar.bz2
upstream-fff02093e602f7c49161746305a4b13c1a2bb441.zip
brcm2708: add squashfs rootfs image
This patch adds a image with squashfs as the root filesystem. A rootfs_data partition will be generated on the first boot and placed inside the rootfs partition (just after the squashfs image). advantages: - it is possible to migrate from an existing -ext4 installation and back via sysupgrade. - existing partition layout will not be lost. - slightly smaller image size. - support for attendedsysupgrade disadvantages: - needs f2fs + tools as well. This is because fs-tools decides on the blocksize of the sdcard. So either f2fs or ext4 can get choosen as the rootfs_data filesystem (depends on the size of the root partition). - rootfs_data is placed into the rootfs partition. This makes it difficult for tools that expect a /dev/mmc0pX device. It also makes it difficult for data recovery tools since they might not expect to find a embedded partition or will be confused. For people with existing build configurations: make sure to include mkf2fs and f2fsck package into the image... Otherwise the new -squashfs image will boot of a ram-overlay and won't keep the configurations after a reboot. Cc: Álvaro Fernández Rojas <noltari@gmail.com> Cc: Paul Spooren <spooren@informatik.uni-leipzig.de> Cc: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> Acked-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 707b6c815bba34e9783d2695020bb17385fdcf1d)
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile1
-rw-r--r--target/linux/brcm2708/image/cmdline.txt2
2 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 691212de9f..326ef5a0ee 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -47,7 +47,6 @@ endef
### Devices ###
define Device/Default
- FILESYSTEMS := ext4
KERNEL := kernel-bin | kernel-img
KERNEL_IMG := kernel.img
IMAGES := sdcard.img.gz
diff --git a/target/linux/brcm2708/image/cmdline.txt b/target/linux/brcm2708/image/cmdline.txt
index 24f4f0c276..c1099afb00 100644
--- a/target/linux/brcm2708/image/cmdline.txt
+++ b/target/linux/brcm2708/image/cmdline.txt
@@ -1 +1 @@
-dwc_otg.lpm_enable=0 console=serial0,115200 kgdboc=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait
+dwc_otg.lpm_enable=0 console=serial0,115200 kgdboc=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait