aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-14 17:21:19 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-14 18:15:33 +0200
commit037ef13a161c6167b328aaf6ca0e259a5b7db037 (patch)
tree2601e5e3bad7bc780f580ff8f6c7efb711d233de /target/linux/brcm2708/image/Makefile
parenta2f17214cd40c3557db34e262b28e25dcbf47edf (diff)
downloadupstream-037ef13a161c6167b328aaf6ca0e259a5b7db037.tar.gz
upstream-037ef13a161c6167b328aaf6ca0e259a5b7db037.tar.bz2
upstream-037ef13a161c6167b328aaf6ca0e259a5b7db037.zip
brcm2708: move wifi calibration EEPROMs out of base-files
Ship EEPROM blobs for specific supported board only and don't have them lurking around in our source tree but rather download them from @github/RPi-Distro/firmware-nonfree upstream. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 326ef5a0ee..69c1d83fbf 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -66,6 +66,7 @@ define Device/rpi-2
DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,3-model-b-plus raspberrypi,compute-module-3
+ DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
endef
ifeq ($(SUBTARGET),bcm2709)
TARGET_DEVICES += rpi-2
@@ -76,6 +77,7 @@ define Device/rpi-3
DEVICE_TITLE := Raspberry Pi 3B/3B+
DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus
SUPPORTED_DEVICES := rpi-3-b rpi-3-b-plus raspberrypi,3-model-b raspberrypi,3-model-b-plus
+ DEVICE_PACKAGES := brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3