aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-16 13:42:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-16 13:42:35 +0000
commit431576e9ccdb4b87bb0549eb5ff6f0dd68a6043f (patch)
tree78ebd7830e6ba58059a704e0ebca2d5a46d85c87 /target/linux/brcm-2.6
parentb234ecfdf410bc2e7fb927edc80c836ccab51866 (diff)
downloadupstream-431576e9ccdb4b87bb0549eb5ff6f0dd68a6043f.tar.gz
upstream-431576e9ccdb4b87bb0549eb5ff6f0dd68a6043f.tar.bz2
upstream-431576e9ccdb4b87bb0549eb5ff6f0dd68a6043f.zip
accidentally removed a small part of the flash map patch - fixing that.
SVN-Revision: 5158
Diffstat (limited to 'target/linux/brcm-2.6')
-rw-r--r--target/linux/brcm-2.6/patches/002-flash-map.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/brcm-2.6/patches/002-flash-map.patch b/target/linux/brcm-2.6/patches/002-flash-map.patch
index 0f9c5ada99..a1cbe03290 100644
--- a/target/linux/brcm-2.6/patches/002-flash-map.patch
+++ b/target/linux/brcm-2.6/patches/002-flash-map.patch
@@ -492,3 +492,30 @@ diff -urN linux.old/drivers/mtd/maps/bcm47xx-flash.c linux.dev/drivers/mtd/maps/
+
+module_init(init_bcm947xx_map);
+module_exit(cleanup_bcm947xx_map);
+diff -urN linux.old/drivers/mtd/maps/Kconfig linux.dev/drivers/mtd/maps/Kconfig
+--- linux.old/drivers/mtd/maps/Kconfig 2006-06-23 19:13:51.000000000 +0200
++++ linux.dev/drivers/mtd/maps/Kconfig 2006-06-23 18:47:58.000000000 +0200
+@@ -299,6 +299,12 @@
+ Mapping for the Flaga digital module. If you don't have one, ignore
+ this setting.
+
++config MTD_BCM47XX
++ tristate "BCM47xx flash device"
++ depends on MIPS && MTD_CFI && BCM947XX
++ help
++ Support for the flash chips on the BCM947xx board.
++
+ config MTD_BEECH
+ tristate "CFI Flash device mapped on IBM 405LP Beech"
+ depends on MTD_CFI && BEECH
+diff -urN linux.old/drivers/mtd/maps/Makefile linux.dev/drivers/mtd/maps/Makefile
+--- linux.old/drivers/mtd/maps/Makefile 2006-06-23 19:13:51.000000000 +0200
++++ linux.dev/drivers/mtd/maps/Makefile 2006-06-23 18:47:58.000000000 +0200
+@@ -30,6 +30,7 @@
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+ obj-$(CONFIG_MTD_IPAQ) += ipaq-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o