aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/patches
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-06-14 11:36:58 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-06-14 11:36:58 +0000
commit8d5a0d9721c7df5a485ef4d63266553454c9a879 (patch)
tree1bb69e4b9fb71cd7ec88d62bb55103080c3285f1 /target/linux/brcm-2.4/patches
parentaf432e7a526864617c1e39ea049e745950e5bbdb (diff)
downloadupstream-8d5a0d9721c7df5a485ef4d63266553454c9a879.tar.gz
upstream-8d5a0d9721c7df5a485ef4d63266553454c9a879.tar.bz2
upstream-8d5a0d9721c7df5a485ef4d63266553454c9a879.zip
This patch adds some vital exports for fuse24 to the kernel. (forgotten in #5186) Closes #5333
SVN-Revision: 16448
Diffstat (limited to 'target/linux/brcm-2.4/patches')
-rw-r--r--target/linux/brcm-2.4/patches/016-fuse-ntfs-3g-mips.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/patches/016-fuse-ntfs-3g-mips.patch b/target/linux/brcm-2.4/patches/016-fuse-ntfs-3g-mips.patch
new file mode 100644
index 0000000000..c1031a3399
--- /dev/null
+++ b/target/linux/brcm-2.4/patches/016-fuse-ntfs-3g-mips.patch
@@ -0,0 +1,30 @@
+--- a/arch/mips/mm/c-r4k.c
++++ b/arch/mips/mm/c-r4k.c
+@@ -325,7 +325,7 @@ static void r4k_flush_cache_mm(struct mm
+ r4k_blast_scache();
+ }
+
+-static void r4k_flush_cache_page(struct vm_area_struct *vma,
++void r4k_flush_cache_page(struct vm_area_struct *vma,
+ unsigned long page)
+ {
+ int exec = vma->vm_flags & VM_EXEC;
+@@ -385,6 +385,7 @@ static void r4k_flush_cache_page(struct
+ r4k_blast_icache_page_indexed(page);
+ }
+ }
++EXPORT_SYMBOL(r4k_flush_cache_page);
+
+ static void r4k_flush_data_cache_page(unsigned long addr)
+ {
+--- a/arch/mips/mm/Makefile
++++ b/arch/mips/mm/Makefile
+@@ -11,7 +11,7 @@ USE_STANDARD_AS_RULE := true
+ O_TARGET := mm.o
+
+ export-objs := cache.o ioremap.o loadmmu.o remap.o \
+- tlb-r4k.o tlb-sb1.o
++ tlb-r4k.o tlb-sb1.o c-r4k.o
+ obj-y += cache.o extable.o init.o ioremap.o fault.o \
+ loadmmu.o
+