aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/patches
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-16 15:11:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-16 15:11:52 +0000
commit2a4a1eeae38fe70ff5e28682ce3ee2be32a3ba3b (patch)
tree8e1fe85799647f897b5eb9ae0b8ee3a6130120e2 /target/linux/brcm-2.4/patches
parent39f2b6d957cd512d95104656da0df5852e463308 (diff)
downloadupstream-2a4a1eeae38fe70ff5e28682ce3ee2be32a3ba3b.tar.gz
upstream-2a4a1eeae38fe70ff5e28682ce3ee2be32a3ba3b.tar.bz2
upstream-2a4a1eeae38fe70ff5e28682ce3ee2be32a3ba3b.zip
fix serial flash support (#6442)
SVN-Revision: 19171
Diffstat (limited to 'target/linux/brcm-2.4/patches')
-rw-r--r--target/linux/brcm-2.4/patches/004-flash.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/patches/004-flash.patch b/target/linux/brcm-2.4/patches/004-flash.patch
index f34efb0146..7de8a82eb6 100644
--- a/target/linux/brcm-2.4/patches/004-flash.patch
+++ b/target/linux/brcm-2.4/patches/004-flash.patch
@@ -1,3 +1,13 @@
+--- a/arch/mips/bcm947xx/Makefile
++++ b/arch/mips/bcm947xx/Makefile
+@@ -11,6 +11,7 @@
+ obj-y := prom.o setup.o time.o sbmips.o gpio.o
+ obj-y += nvram.o nvram_linux.o cfe_env.o hndpmu.o
+ obj-y += sbutils.o utils.o bcmsrom.o hndchipc.o
++obj-y += sflash.o
+ obj-$(CONFIG_PCI) += sbpci.o pcibios.o
+ obj-y += export.o
+
--- a/drivers/mtd/devices/Config.in
+++ b/drivers/mtd/devices/Config.in
@@ -5,6 +5,7 @@