aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-03-23 20:12:22 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-03-23 20:12:22 +0100
commit7f04d675170d255580edf77d4ff7c0adebb57609 (patch)
tree4cc1d76bc8d8497ef63c1a7b6ce68bd0d32eac9e /target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch
parent851dadc257b7223f879a3733507e83cfcaae1af1 (diff)
downloadupstream-7f04d675170d255580edf77d4ff7c0adebb57609.tar.gz
upstream-7f04d675170d255580edf77d4ff7c0adebb57609.tar.bz2
upstream-7f04d675170d255580edf77d4ff7c0adebb57609.zip
bmips: add experimental PCI/PCIe support
These PCI drivers are a bit hacky and definitely not suitable for upstreaming, but hopefully we can use them as a base for developing proper upstream PCI drivers. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch')
-rw-r--r--target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch b/target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch
new file mode 100644
index 0000000000..c0572604ee
--- /dev/null
+++ b/target/linux/bmips/patches-5.10/603-pci-controllers-add-bcm6348-pci-support.patch
@@ -0,0 +1,22 @@
+--- a/drivers/pci/controller/Kconfig
++++ b/drivers/pci/controller/Kconfig
+@@ -3,6 +3,11 @@
+ menu "PCI controller drivers"
+ depends on PCI
+
++config PCI_BCM6348
++ bool "BCM6348 PCI controller"
++ depends on BMIPS_GENERIC || COMPILE_TEST
++ depends on OF
++
+ config PCIE_BCM6318
+ bool "BCM6318 PCIe controller"
+ depends on BMIPS_GENERIC || COMPILE_TEST
+--- a/drivers/pci/controller/Makefile
++++ b/drivers/pci/controller/Makefile
+@@ -1,4 +1,5 @@
+ # SPDX-License-Identifier: GPL-2.0
++obj-$(CONFIG_PCI_BCM6348) += pci-bcm6348.o
+ obj-$(CONFIG_PCIE_BCM6318) += pcie-bcm6318.o
+ obj-$(CONFIG_PCIE_BCM6328) += pcie-bcm6328.o
+ obj-$(CONFIG_PCIE_CADENCE) += cadence/