aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-22 18:07:02 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2021-02-22 18:29:44 +0100
commitc27532742d8cae7b9c1a8c2fbfe5157e65a20877 (patch)
tree885a63986c85d49db17a046e9481eec3f3fcf78e /target/linux/bcm63xx
parent1235ea7c205c313e8dbb5c46917b8739abbfb152 (diff)
downloadupstream-c27532742d8cae7b9c1a8c2fbfe5157e65a20877.tar.gz
upstream-c27532742d8cae7b9c1a8c2fbfe5157e65a20877.tar.bz2
upstream-c27532742d8cae7b9c1a8c2fbfe5157e65a20877.zip
bcm63xx: limit name metadata to model name
Since there are only 16 characters available, on most cases the vendor name will fit in the metadata, but the model name won't fit. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm63xx')
-rw-r--r--target/linux/bcm63xx/image/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index 822e26e993..f35358173c 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -84,10 +84,6 @@ endef
define rootfspad/squashfs
endef
-define Image/LimitName16
-$(shell expr substr "$(1)" 1 16)
-endef
-
define Image/FileSystemStrip
$(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
endef
@@ -96,7 +92,7 @@ define Build/cfe-bin
$(STAGING_DIR_HOST)/bin/imagetag -i $(IMAGE_KERNEL) -f $(IMAGE_ROOTFS) \
--output $@ --boardid $(CFE_BOARD_ID) --chipid $(CHIP_ID) \
--entry $(LOADER_ENTRY) --load-addr $(LOADER_ENTRY) \
- --info1 "$(call Image/LimitName16,$(DEVICE_NAME))" \
+ --info1 "$(call ModelNameLimit16,$(DEVICE_NAME))" \
--info2 "$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))" \
$(call rootfspad/$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))) \
$(CFE_EXTRAS) $(1)