aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm63xx
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-27 12:30:41 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-20 14:19:39 +0200
commita14f5bb4bd263c21e103f13279d0c2ff03e48fe5 (patch)
tree18eecef0be1356f014d81b0427471ae18c8839c2 /target/linux/bcm63xx
parentcc75344044e5c16cd4994d824db5779a5ac057c2 (diff)
downloadupstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.gz
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.bz2
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.zip
treewide: use wpad-basic-wolfssl as default
In order to support SAE/WPA3-Personal in default images. Replace almost all occurencies of wpad-basic and wpad-mini with wpad-basic-wolfssl for consistency. Keep out ar71xx from the list as it won't be in the next release and would only make backports harder. Build-tested (build-bot settings): ath79: generic, ramips: mt7620/mt76x8/rt305x, lantiq: xrx200/xway, sunxi: a53 Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebase, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm63xx')
-rw-r--r--target/linux/bcm63xx/image/Makefile10
-rw-r--r--target/linux/bcm63xx/profiles/default.mk2
2 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index 90d87f7bd4..d8e68862b3 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -311,12 +311,12 @@ define Device/Default
endef
DEVICE_VARS += CHIP_ID DEVICE_LOADADDR
-ATH5K_PACKAGES := kmod-ath5k wpad-basic
-ATH9K_PACKAGES := kmod-ath9k wpad-basic
-B43_PACKAGES := kmod-b43 wpad-basic
+ATH5K_PACKAGES := kmod-ath5k wpad-basic-wolfssl
+ATH9K_PACKAGES := kmod-ath9k wpad-basic-wolfssl
+B43_PACKAGES := kmod-b43 wpad-basic-wolfssl
BRCMWL_PACKAGES := kmod-brcm-wl nas wlc
-RT28_PACKAGES := kmod-rt2800-pci wpad-basic
-RT61_PACKAGES := kmod-rt61-pci wpad-basic
+RT28_PACKAGES := kmod-rt2800-pci wpad-basic-wolfssl
+RT61_PACKAGES := kmod-rt61-pci wpad-basic-wolfssl
USB1_PACKAGES := kmod-usb-ohci kmod-usb-ledtrig-usbport
USB2_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
diff --git a/target/linux/bcm63xx/profiles/default.mk b/target/linux/bcm63xx/profiles/default.mk
index 95cd67c46e..2df9d062ff 100644
--- a/target/linux/bcm63xx/profiles/default.mk
+++ b/target/linux/bcm63xx/profiles/default.mk
@@ -7,7 +7,7 @@
define Profile/Default
NAME:=Default Profile
- PACKAGES:=kmod-b43 wpad-basic
+ PACKAGES:=kmod-b43 wpad-basic-wolfssl
PRIORITY:=1
endef