aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-22 15:55:43 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-25 18:11:06 +0100
commitef2cb8572b48f1e1964b4d1d014d16cb721b5175 (patch)
tree595fb4d12164bfa78c653c897428002ec69dfd1d /target/linux/bcm53xx
parent198385b69de14494e282035a2293fc253f839864 (diff)
downloadupstream-ef2cb8572b48f1e1964b4d1d014d16cb721b5175.tar.gz
upstream-ef2cb8572b48f1e1964b4d1d014d16cb721b5175.tar.bz2
upstream-ef2cb8572b48f1e1964b4d1d014d16cb721b5175.zip
treewide: rename IMAGE_PREFIX/IMAGE_NAME to DEVICE_IMG_*
We so far had two variables IMG_PREFIX and IMAGE_PREFIX with different content. Since these names are obviously quite confusing, this patch renames the latter to DEVICE_IMG_PREFIX, as it's a device-dependent variable, while IMG_PREFIX is only (sub)target-dependent. For consistency, also rename IMAGE_NAME to DEVICE_IMG_NAME, as that's a device-dependent variable as well. Cc: Paul Spooren <mail@aparcar.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 0ba067d364..86d241f57f 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -130,7 +130,7 @@ define Device/Default
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma-d16 | trx
FILESYSTEMS := squashfs
KERNEL_NAME := zImage
- IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
+ DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(1).$$(2)
IMAGES := trx
BLOCKSIZE := 128k
PAGESIZE := 2048