aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-04-12 11:59:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-04-12 11:59:07 +0000
commitd2812cb036585a9dfe3147e691b4ec3dc3a188d8 (patch)
treeb6c8c1de129dfd7a840c57a803912a693693e469 /target/linux/bcm53xx
parent17f848538cb9d219533e485642514d4085766604 (diff)
downloadupstream-d2812cb036585a9dfe3147e691b4ec3dc3a188d8.tar.gz
upstream-d2812cb036585a9dfe3147e691b4ec3dc3a188d8.tar.bz2
upstream-d2812cb036585a9dfe3147e691b4ec3dc3a188d8.zip
kernel: update 3.10 to 3.10.36
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 40467
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/Makefile2
-rw-r--r--target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
index edcf137561..339e7cddb8 100644
--- a/target/linux/bcm53xx/Makefile
+++ b/target/linux/bcm53xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
CPU_TYPE:=cortex-a9
-LINUX_VERSION:=3.10.34
+LINUX_VERSION:=3.10.36
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch b/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch
index 78154707e7..c23e205218 100644
--- a/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch
+++ b/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch
@@ -31,7 +31,7 @@ The PHY says it is not connected by default, just ignore it.
static const struct bcma_device_id bgmac_bcma_tbl[] = {
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_4706_MAC_GBIT, BCMA_ANY_REV, BCMA_ANY_CLASS),
-@@ -1438,7 +1442,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -1452,7 +1456,7 @@ static int bgmac_probe(struct bcma_devic
int err;
/* We don't support 2nd, 3rd, ... units, SPROM has to be adjusted */
@@ -40,7 +40,7 @@ The PHY says it is not connected by default, just ignore it.
pr_err("Unsupported core_unit %d\n", core->core_unit);
return -ENOTSUPP;
}
-@@ -1473,8 +1477,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -1487,8 +1491,7 @@ static int bgmac_probe(struct bcma_devic
}
bgmac->cmn = core->bus->drv_gmac_cmn.core;
@@ -50,7 +50,7 @@ The PHY says it is not connected by default, just ignore it.
bgmac->phyaddr &= BGMAC_PHY_MASK;
if (bgmac->phyaddr == BGMAC_PHY_MASK) {
bgmac_err(bgmac, "No PHY found\n");
-@@ -1526,8 +1529,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -1540,8 +1543,7 @@ static int bgmac_probe(struct bcma_devic
/* TODO: reset the external phy. Specs are needed */
bgmac_phy_reset(bgmac);