aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-04 16:02:56 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-12 11:08:05 +0200
commit683bcbdce163375286c8193cc76c130f02e6649f (patch)
treea393945dcf5f705f0e9d4af2ae846493518ce091 /target/linux/bcm53xx
parent0002d177e4d92aa6e0ead12b6cce6a3c1a693183 (diff)
downloadupstream-683bcbdce163375286c8193cc76c130f02e6649f.tar.gz
upstream-683bcbdce163375286c8193cc76c130f02e6649f.tar.bz2
upstream-683bcbdce163375286c8193cc76c130f02e6649f.zip
bcm53xx: use vendor_model scheme for device/image names
Most targets have been updated to consistently use the vendor_model scheme for device definitions and thus, image names. Apply this to bcm53xx as well. This does _not_ apply any other specific naming changes. Cc: Rafał Miłecki <rafal@milecki.pl> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile114
1 files changed, 57 insertions, 57 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index a117e02a45..c490192b8a 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -125,7 +125,7 @@ USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
define Device/Default
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
# extract the full dtb name based on the device info
- DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+ DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(subst _,-,$(1)).dtb)))
KERNEL := kernel-bin | append-dtb | lzma-d16
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_SUFFIX := .trx
@@ -145,37 +145,37 @@ define Device/asus
IMAGE/trx := append-ubi | trx-nand | asus-trx
endef
-define Device/asus-rt-ac56u
+define Device/asus_rt-ac56u
$(call Device/asus)
DEVICE_MODEL := RT-AC56U
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
ASUS_PRODUCTID := RT-AC56U
endef
-TARGET_DEVICES += asus-rt-ac56u
+TARGET_DEVICES += asus_rt-ac56u
-define Device/asus-rt-ac68u
+define Device/asus_rt-ac68u
$(call Device/asus)
DEVICE_MODEL := RT-AC68U
DEVICE_PACKAGES := $(USB3_PACKAGES)
ASUS_PRODUCTID := RT-AC68U
endef
-TARGET_DEVICES += asus-rt-ac68u
+TARGET_DEVICES += asus_rt-ac68u
-define Device/asus-rt-ac87u
+define Device/asus_rt-ac87u
$(call Device/asus)
DEVICE_MODEL := RT-AC87U
DEVICE_PACKAGES := $(USB3_PACKAGES)
ASUS_PRODUCTID := RT-AC87U
endef
-TARGET_DEVICES += asus-rt-ac87u
+TARGET_DEVICES += asus_rt-ac87u
-define Device/asus-rt-n18u
+define Device/asus_rt-n18u
$(call Device/asus)
DEVICE_MODEL := RT-N18U
DEVICE_PACKAGES := $(USB3_PACKAGES)
ASUS_PRODUCTID := RT-N18U
endef
-TARGET_DEVICES += asus-rt-n18u
+TARGET_DEVICES += asus_rt-n18u
# Buffalo devices have TFTP recovery mode which can work nicely with initramfs
# kernels.
@@ -188,21 +188,21 @@ define Device/buffalo/Default
KERNEL_INITRAMFS = $$(KERNEL)
endef
-define Device/buffalo-wxr-1900dhp
+define Device/buffalo_wxr-1900dhp
$(call Device/buffalo/Default)
DEVICE_MODEL := WXR-1900DHP
DEVICE_PACKAGES := $(USB3_PACKAGES)
endef
-TARGET_DEVICES += buffalo-wxr-1900dhp
+TARGET_DEVICES += buffalo_wxr-1900dhp
-define Device/buffalo-wzr-600dhp2
+define Device/buffalo_wzr-600dhp2
$(call Device/buffalo/Default)
DEVICE_MODEL := WZR-600DHP2
DEVICE_PACKAGES := $(B43) $(USB2_PACKAGES)
endef
-TARGET_DEVICES += buffalo-wzr-600dhp2
+TARGET_DEVICES += buffalo_wzr-600dhp2
-define Device/buffalo-wzr-900dhp
+define Device/buffalo_wzr-900dhp
$(call Device/buffalo/Default)
DEVICE_MODEL := WZR-900DHP
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
@@ -221,14 +221,14 @@ define Device/buffalo-wzr-900dhp
buffalo-tag-dhp WZR-900DHP2 JP jp | buffalo-enc-tag | \
buffalo-dhp-image
endef
-TARGET_DEVICES += buffalo-wzr-900dhp
+TARGET_DEVICES += buffalo_wzr-900dhp
-define Device/buffalo-wzr-1750dhp
+define Device/buffalo_wzr-1750dhp
$(call Device/buffalo/Default)
DEVICE_MODEL := WZR-1750DHP
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
endef
-TARGET_DEVICES += buffalo-wzr-1750dhp
+TARGET_DEVICES += buffalo_wzr-1750dhp
define Device/dlink
DEVICE_VENDOR := D-Link
@@ -236,49 +236,49 @@ define Device/dlink
IMAGE/bin := append-ubi | seama-nand
endef
-define Device/dlink-dir-885l
+define Device/dlink_dir-885l
DEVICE_MODEL := DIR-885L
DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(USB3_PACKAGES)
$(Device/dlink)
SIGNATURE := wrgac42_dlink.2015_dir885l
endef
-TARGET_DEVICES += dlink-dir-885l
+TARGET_DEVICES += dlink_dir-885l
# Linksys devices are disabled due to problem with 2 TRX partitions
-define Device/linksys-ea6300-v1
+define Device/linksys_ea6300-v1
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA6300
DEVICE_VARIANT := v1
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
BROKEN := y
endef
-TARGET_DEVICES += linksys-ea6300-v1
+TARGET_DEVICES += linksys_ea6300-v1
-define Device/linksys-ea6500-v2
+define Device/linksys_ea6500-v2
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA6500
DEVICE_VARIANT := v2
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
endef
-TARGET_DEVICES += linksys-ea6500-v2
+TARGET_DEVICES += linksys_ea6500-v2
-define Device/linksys-ea9200
+define Device/linksys_ea9200
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA9200
DEVICE_VARIANT := v1
DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
BROKEN := y
endef
-TARGET_DEVICES += linksys-ea9200
+TARGET_DEVICES += linksys_ea9200
-define Device/linksys-ea9500
+define Device/linksys_ea9500
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA9500
DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
DEVICE_DTS := bcm47094-linksys-panamera
BROKEN := y
endef
-TARGET_DEVICES += linksys-ea9500
+TARGET_DEVICES += linksys_ea9500
define Device/luxul
DEVICE_VENDOR := Luxul
@@ -286,39 +286,39 @@ define Device/luxul
IMAGE/lxl := append-ubi | trx-nand | luxul-lxl
endef
-define Device/luxul-abr-4500
+define Device/luxul_abr-4500
$(Device/luxul)
DEVICE_MODEL := ABR-4500
DEVICE_PACKAGES := $(USB3_PACKAGES)
LUXUL_BOARD := ABR-4500
endef
-TARGET_DEVICES += luxul-abr-4500
+TARGET_DEVICES += luxul_abr-4500
-define Device/luxul-xap-1610
+define Device/luxul_xap-1610
$(Device/luxul)
DEVICE_MODEL := XAP-1610
DEVICE_PACKAGES := $(BRCMFMAC_4366C0)
IMAGE/lxl := append-rootfs | trx-serial | luxul-lxl
LUXUL_BOARD := XAP-1610
endef
-TARGET_DEVICES += luxul-xap-1610
+TARGET_DEVICES += luxul_xap-1610
-define Device/luxul-xbr-4500
+define Device/luxul_xbr-4500
$(Device/luxul)
DEVICE_MODEL := XBR-4500
DEVICE_PACKAGES := $(USB3_PACKAGES)
LUXUL_BOARD := XBR-4500
endef
-TARGET_DEVICES += luxul-xbr-4500
+TARGET_DEVICES += luxul_xbr-4500
-define Device/luxul-xwr-3150
+define Device/luxul_xwr-3150
$(Device/luxul)
DEVICE_MODEL := XWR-3150
DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
DEVICE_DTS := bcm47094-luxul-xwr-3150-v1
LUXUL_BOARD := XWR-3150
endef
-TARGET_DEVICES += luxul-xwr-3150
+TARGET_DEVICES += luxul_xwr-3150
define Device/netgear
DEVICE_VENDOR := NETGEAR
@@ -327,57 +327,57 @@ define Device/netgear
NETGEAR_REGION := 1
endef
-define Device/netgear-r6250
+define Device/netgear_r6250
DEVICE_MODEL := R6250
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H245T00_NETGEAR
endef
-TARGET_DEVICES += netgear-r6250
+TARGET_DEVICES += netgear_r6250
-define Device/netgear-r6300-v2
+define Device/netgear_r6300-v2
DEVICE_MODEL := R6300
DEVICE_VARIANT := v2
DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H240T00_NETGEAR
endef
-TARGET_DEVICES += netgear-r6300-v2
+TARGET_DEVICES += netgear_r6300-v2
-define Device/netgear-r7000
+define Device/netgear_r7000
DEVICE_MODEL := R7000
DEVICE_PACKAGES := $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H270T00_NETGEAR
endef
-TARGET_DEVICES += netgear-r7000
+TARGET_DEVICES += netgear_r7000
-define Device/netgear-r7900
+define Device/netgear_r7900
DEVICE_MODEL := R7900
DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H315T30_NETGEAR
endef
-TARGET_DEVICES += netgear-r7900
+TARGET_DEVICES += netgear_r7900
-define Device/netgear-r8000
+define Device/netgear_r8000
DEVICE_MODEL := R8000
DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H315T00_NETGEAR
endef
-TARGET_DEVICES += netgear-r8000
+TARGET_DEVICES += netgear_r8000
-define Device/netgear-r8500
+define Device/netgear_r8500
DEVICE_MODEL := R8500
DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H334T00_NETGEAR
DEFAULT := n
endef
-TARGET_DEVICES += netgear-r8500
+TARGET_DEVICES += netgear_r8500
-define Device/smartrg-sr400ac
+define Device/smartrg_sr400ac
DEVICE_VENDOR := SmartRG
DEVICE_MODEL := SR400ac
DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
@@ -386,26 +386,26 @@ define Device/smartrg-sr400ac
KERNEL_INITRAMFS_SUFFIX := .bin
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma-d16
endef
-TARGET_DEVICES += smartrg-sr400ac
+TARGET_DEVICES += smartrg_sr400ac
-define Device/phicomm-k3
+define Device/phicomm_k3
DEVICE_VENDOR := PHICOMM
DEVICE_MODEL := K3
DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
IMAGES := trx
endef
-TARGET_DEVICES += phicomm-k3
+TARGET_DEVICES += phicomm_k3
-define Device/tenda-ac9
+define Device/tenda_ac9
DEVICE_VENDOR := Tenda
DEVICE_MODEL := AC9
DEVICE_PACKAGES := $(B43) $(USB2_PACKAGES)
IMAGES := trx
IMAGE/trx := append-rootfs | trx-serial
endef
-TARGET_DEVICES += tenda-ac9
+TARGET_DEVICES += tenda_ac9
-define Device/tplink-archer-c5-v2
+define Device/tplink_archer-c5-v2
DEVICE_VENDOR := TP-LINK
DEVICE_MODEL := Archer C5
DEVICE_VARIANT := v2
@@ -415,9 +415,9 @@ define Device/tplink-archer-c5-v2
TPLINK_BOARD := ARCHER-C5-V2
BROKEN := y
endef
-TARGET_DEVICES += tplink-archer-c5-v2
+TARGET_DEVICES += tplink_archer-c5-v2
-define Device/tplink-archer-c9-v1
+define Device/tplink_archer-c9-v1
DEVICE_VENDOR := TP-LINK
DEVICE_MODEL := Archer C9
DEVICE_VARIANT := v1
@@ -427,6 +427,6 @@ define Device/tplink-archer-c9-v1
TPLINK_BOARD := ARCHERC9
BROKEN := y
endef
-TARGET_DEVICES += tplink-archer-c9-v1
+TARGET_DEVICES += tplink_archer-c9-v1
$(eval $(call BuildImage))