aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-08-17 20:44:52 +0200
committerRafał Miłecki <rafal@milecki.pl>2022-09-03 20:56:06 +0200
commit4efa0b70d54f1b1129051656628be452578f3fa4 (patch)
tree5cdb26fb9017f1eba32943e2727879e3ccc5f48e /target/linux/bcm53xx
parent8835da4d9047cb11d6267b59cf414bd4de3984bc (diff)
downloadupstream-4efa0b70d54f1b1129051656628be452578f3fa4.tar.gz
upstream-4efa0b70d54f1b1129051656628be452578f3fa4.tar.bz2
upstream-4efa0b70d54f1b1129051656628be452578f3fa4.zip
kernel: backport U-Boot environment data NVMEM driver
It parses U-Boot env data into NVMEM cells. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 34cf31043504473df3174a22d163b71b75e46542)
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/patches-5.10/080-v5.13-0002-nvmem-brcm_nvram-new-driver-exposing-Broadcom-s-NVRA.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/bcm53xx/patches-5.10/080-v5.13-0002-nvmem-brcm_nvram-new-driver-exposing-Broadcom-s-NVRA.patch b/target/linux/bcm53xx/patches-5.10/080-v5.13-0002-nvmem-brcm_nvram-new-driver-exposing-Broadcom-s-NVRA.patch
index ac89ea4bc2..3a8940b36a 100644
--- a/target/linux/bcm53xx/patches-5.10/080-v5.13-0002-nvmem-brcm_nvram-new-driver-exposing-Broadcom-s-NVRA.patch
+++ b/target/linux/bcm53xx/patches-5.10/080-v5.13-0002-nvmem-brcm_nvram-new-driver-exposing-Broadcom-s-NVRA.patch
@@ -19,9 +19,9 @@ Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
--- a/drivers/nvmem/Kconfig
+++ b/drivers/nvmem/Kconfig
-@@ -270,4 +270,13 @@ config SPRD_EFUSE
- This driver can also be built as a module. If so, the module
- will be called nvmem-sprd-efuse.
+@@ -283,4 +283,13 @@ config NVMEM_U_BOOT_ENV
+
+ If compiled as module it will be called nvmem_u-boot-env.
+
+config NVMEM_BRCM_NVRAM
@@ -35,10 +35,10 @@ Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
endif
--- a/drivers/nvmem/Makefile
+++ b/drivers/nvmem/Makefile
-@@ -55,3 +55,5 @@ obj-$(CONFIG_NVMEM_ZYNQMP) += nvmem_zynq
- nvmem_zynqmp_nvmem-y := zynqmp_nvmem.o
- obj-$(CONFIG_SPRD_EFUSE) += nvmem_sprd_efuse.o
+@@ -57,3 +57,5 @@ obj-$(CONFIG_SPRD_EFUSE) += nvmem_sprd_e
nvmem_sprd_efuse-y := sprd-efuse.o
+ obj-$(CONFIG_NVMEM_U_BOOT_ENV) += nvmem_u-boot-env.o
+ nvmem_u-boot-env-y := u-boot-env.o
+obj-$(CONFIG_NVMEM_BRCM_NVRAM) += nvmem_brcm_nvram.o
+nvmem_brcm_nvram-y := brcm_nvram.o
--- /dev/null