aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/profiles
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-07-12 13:46:27 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-07-12 13:46:27 +0000
commit21201be1f4a0b915ef8c32ae34afefff58d4f42c (patch)
tree42e9e85c31ce67c40103d9267bda76e5fa957bf6 /target/linux/bcm53xx/profiles
parent089d2c0e73fb6cbcbedd7d1cfc03b183c7075fd9 (diff)
downloadupstream-21201be1f4a0b915ef8c32ae34afefff58d4f42c.tar.gz
upstream-21201be1f4a0b915ef8c32ae34afefff58d4f42c.tar.bz2
upstream-21201be1f4a0b915ef8c32ae34afefff58d4f42c.zip
bcm53xx: add initial support for ARM based BCM47XX and BCM53XX SoCs
This was only tested on a Netgear R6250, but it could also work on other devices when the correct images are generated. It is only possible to boot into a ram disk, no Ethernet, Wifi, flash, USB is supported. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37268 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/profiles')
-rw-r--r--target/linux/bcm53xx/profiles/100-Generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/profiles/100-Generic.mk b/target/linux/bcm53xx/profiles/100-Generic.mk
new file mode 100644
index 0000000000..5e6d1ce85d
--- /dev/null
+++ b/target/linux/bcm53xx/profiles/100-Generic.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Broadcom SoC, BCM43xx WiFi (b43, default)
+endef
+
+define Profile/Generic/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with a ARM CPU like the BCM4707, BCM4708, BCM4709, BCM53010
+endef
+
+$(eval $(call Profile,Generic))
+