aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2018-12-27 07:01:38 +0100
committerRafał Miłecki <rafal@milecki.pl>2018-12-27 08:28:44 +0100
commitdbbba84ed4f85924e49da220727adf2abaeb3c2a (patch)
treec28b230d99093cb233fb08d5d0cd09fc80c5f31d /target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch
parenteef6bd3393f406f73187a670fa34d5e6a228f9e8 (diff)
downloadupstream-dbbba84ed4f85924e49da220727adf2abaeb3c2a.tar.gz
upstream-dbbba84ed4f85924e49da220727adf2abaeb3c2a.tar.bz2
upstream-dbbba84ed4f85924e49da220727adf2abaeb3c2a.zip
bcm53xx: rename dts backport patches changing their prefixes
Start 03x with 030 instead of 035. It's a trivial change that adds more place for further backports in the 03x space. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit a5d6f2eb76a549af9e5e186042ab6bf2371be725)
Diffstat (limited to 'target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch')
-rw-r--r--target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch b/target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch
new file mode 100644
index 0000000000..9d43dd58d0
--- /dev/null
+++ b/target/linux/bcm53xx/patches-4.14/030-v4.15-0005-ARM-dts-BCM53573-Add-DT-for-Luxul-XAP-1440.patch
@@ -0,0 +1,83 @@
+From 7030ea600d560026b91726f2eb79c856b813afa9 Mon Sep 17 00:00:00 2001
+From: Dan Haab <dhaab@luxul.com>
+Date: Mon, 9 Oct 2017 09:47:00 -0600
+Subject: [PATCH] ARM: dts: BCM53573: Add DT for Luxul XAP-1440
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This is BCM53573 WiSoC based outdoor access point with an extra BCM43217
+chipset used for 2.4 GHz.
+
+Signed-off-by: Dan Haab <dhaab@luxul.com>
+Acked-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile | 1 +
+ arch/arm/boot/dts/bcm47189-luxul-xap-1440.dts | 50 +++++++++++++++++++++++++++
+ 2 files changed, 51 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47189-luxul-xap-1440.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -111,6 +111,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+ bcm953012hr.dtb \
+ bcm953012k.dtb
+ dtb-$(CONFIG_ARCH_BCM_53573) += \
++ bcm47189-luxul-xap-1440.dtb \
+ bcm47189-luxul-xap-810.dtb \
+ bcm47189-tenda-ac9.dtb \
+ bcm947189acdbmr.dtb
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47189-luxul-xap-1440.dts
+@@ -0,0 +1,50 @@
++/*
++ * Copyright 2017 Luxul Inc.
++ *
++ * Licensed under the ISC license.
++ */
++
++/dts-v1/;
++
++#include "bcm53573.dtsi"
++
++/ {
++ compatible = "luxul,xap-1440-v1", "brcm,bcm47189", "brcm,bcm53573";
++ model = "Luxul XAP-1440 V1";
++
++ chosen {
++ bootargs = "earlycon";
++ };
++
++ memory {
++ reg = <0x00000000 0x08000000>;
++ };
++
++ leds {
++ compatible = "gpio-leds";
++
++ wlan {
++ label = "bcm53xx:blue:wlan";
++ gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "default-off";
++ };
++
++ system {
++ label = "bcm53xx:green:system";
++ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "timer";
++ };
++ };
++
++ gpio-keys {
++ compatible = "gpio-keys";
++ #address-cells = <1>;
++ #size-cells = <0>;
++
++ restart {
++ label = "Reset";
++ linux,code = <KEY_RESTART>;
++ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
++ };
++ };
++};