aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorDan Haab <dan.haab@legrand.com>2020-02-05 10:37:44 -0700
committerRafał Miłecki <rafal@milecki.pl>2020-02-07 09:31:22 +0100
commit1d47f81581bcd476487e5b29314602167a843b99 (patch)
tree44eced1a38d7bca85e6fb70b9b7e1aa523a5dfa6 /target/linux/bcm53xx/image
parent9aa6569aa669767ec9febf1de01a3983a1cb9482 (diff)
downloadupstream-1d47f81581bcd476487e5b29314602167a843b99.tar.gz
upstream-1d47f81581bcd476487e5b29314602167a843b99.tar.bz2
upstream-1d47f81581bcd476487e5b29314602167a843b99.zip
bcm53xx: build images for Luxul ABR-4500 and XBR-4500 routers
Luxul ABR-4500 and XBR-4500 devices are wired routers with 5 Ethernet ports and 1 USB 3.0 port. Flashing requires using Luxul firmware 6.4.0 or newer and uploading firmware using "Firmware Update" web UI page. Signed-off-by: Dan Haab <dan.haab@legrand.com>
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 9f2731ddaa..6f509741ac 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -83,6 +83,13 @@ define Build/asus-trx
mv $@.new $@
endef
+define Build/luxul-lxl
+ $(STAGING_DIR_HOST)/bin/lxlfw create $@.new \
+ -i $@ \
+ -b $(LUXUL_BOARD)
+ mv $@.new $@
+endef
+
define Build/seama-nand
# Seama entity
$(STAGING_DIR_HOST)/bin/oseama \
@@ -102,6 +109,7 @@ endef
DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
+DEVICE_VARS += LUXUL_BOARD
IEEE8021X := wpad-basic
B43 := $(IEEE8021X) kmod-b43
@@ -262,6 +270,28 @@ define Device/linksys-ea9500
endef
# TARGET_DEVICES += linksys-ea9500
+define Device/luxul
+ DEVICE_VENDOR := Luxul
+ IMAGES := lxl
+ IMAGE/lxl := append-ubi | trx-nand | luxul-lxl
+endef
+
+define Device/luxul-abr-4500
+ $(Device/luxul)
+ DEVICE_MODEL := ABR-4500
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+ LUXUL_BOARD := ABR-4500
+endef
+TARGET_DEVICES += luxul-abr-4500
+
+define Device/luxul-xbr-4500
+ $(Device/luxul)
+ DEVICE_MODEL := XBR-4500
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+ LUXUL_BOARD := XBR-4500
+endef
+TARGET_DEVICES += luxul-xbr-4500
+
define Device/netgear
DEVICE_VENDOR := NETGEAR
IMAGES := chk