aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-09-12 22:28:38 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-10-30 15:00:22 +0200
commit6102f883ce7f32988d22b7fc5b79356e3d06c1dc (patch)
tree74d0327a355a6374a594ce0333001b3d22757fea /target/linux/bcm53xx/image/Makefile
parentf5d071a508b3e3d218b8ed6f6f5a999384bb7f6d (diff)
downloadupstream-6102f883ce7f32988d22b7fc5b79356e3d06c1dc.tar.gz
upstream-6102f883ce7f32988d22b7fc5b79356e3d06c1dc.tar.bz2
upstream-6102f883ce7f32988d22b7fc5b79356e3d06c1dc.zip
bcm53xx: MR32: replace i2c-gpio with SoC's i2c
During review of the MR32, Florian Fainelli pointed out that the SoC has a real I2C-controller. Furthermore, the connected pins (SDA and SCL) would line up perfectly for use. This patch swaps out the the bitbanged i2c-gpio with the real deal. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index cb2643ca54..aadac9c3d4 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -318,7 +318,7 @@ TARGET_DEVICES += luxul_xwr-3150
define Device/meraki_mr32
DEVICE_VENDOR := Meraki
DEVICE_MODEL := MR32
- DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc kmod-i2c-gpio kmod-eeprom-at24 \
+ DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc kmod-eeprom-at24 \
kmod-leds-pwm kmod-hwmon-ina2xx kmod-bluetooth
DEVICE_DTS := bcm53016-meraki-mr32
# Meraki FW r23 tries to resize the part.safe partition before it will