aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
authorArınç ÜNAL <arinc.unal@arinc9.com>2022-10-18 11:54:20 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-23 14:21:03 +0200
commit40465adbbf17a6a5445e451c2eb77d5d56e970ac (patch)
tree850f7d625a0bdcc0b1e90749d7d740cfbf19cfd6 /target/linux/bcm53xx/image/Makefile
parentb37ff14302e16a8d749bbda8fd6c1b79ea68df42 (diff)
downloadupstream-40465adbbf17a6a5445e451c2eb77d5d56e970ac.tar.gz
upstream-40465adbbf17a6a5445e451c2eb77d5d56e970ac.tar.bz2
upstream-40465adbbf17a6a5445e451c2eb77d5d56e970ac.zip
bcm53xx: enable Broadcom 4366b1 firmware for Asus RT-AC88U
On some of the hardware revisions of Asus RT-AC88U, brcmfmac detects the 4366b1 wireless chip and tries to load the firmware file which doesn't exist because it's not included in the image. Therefore, include firmware for 4366b1 along with 4366c0. This way, all hardware revisions of the router will be supported by having brcmfmac use the firmware file for the wireless chip it detects. Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com> (cherry picked from commit 2b9bb5b187022f8b64c84781c071d6c2b0ce3e45)
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fc85a131cc..dcfa3a239e 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -170,7 +170,7 @@ TARGET_DEVICES += asus_rt-ac87u
define Device/asus_rt-ac88u
$(call Device/asus)
DEVICE_MODEL := RT-AC88U
- DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
ASUS_PRODUCTID := RT-AC88U
endef
TARGET_DEVICES += asus_rt-ac88u