aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm4908/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-11-19 14:32:58 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-11-19 14:32:58 +0100
commit494c033f9cbad67ea2cee3860894bdfffea65109 (patch)
tree2b722a833a7bb79d0b8a6e2163a100c15eb205f2 /target/linux/bcm4908/image/Makefile
parentebb6f9287e33c3760b076efa6dcc1cce90e1a109 (diff)
downloadupstream-494c033f9cbad67ea2cee3860894bdfffea65109.tar.gz
upstream-494c033f9cbad67ea2cee3860894bdfffea65109.tar.bz2
upstream-494c033f9cbad67ea2cee3860894bdfffea65109.zip
bcm4908: continue work on images for U-Boot based devices
It still isn't ready though - more data needs to be added to the bootfs. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm4908/image/Makefile')
-rw-r--r--target/linux/bcm4908/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/bcm4908/image/Makefile b/target/linux/bcm4908/image/Makefile
index 929e626e0e..8829e64ca1 100644
--- a/target/linux/bcm4908/image/Makefile
+++ b/target/linux/bcm4908/image/Makefile
@@ -5,9 +5,11 @@ include $(INCLUDE_DIR)/image.mk
DEVICE_VARS += ASUS_PRODUCTID ASUS_BUILD_NO ASUS_FW_REV ASUS_EXT_NO
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_REGION
+DEVICE_VARS += PKGTB_ITS
define Image/Prepare
cp bootfs-generic.its $(KDIR)/
+ sed -i "s=\$$$${dts_dir}=$(DTS_DIR)=" $(KDIR)/bootfs-generic.its
endef
define Build/bootfs
@@ -49,6 +51,14 @@ define Build/bcm4908lzma
mv $@.new $@
endef
+define Build/pkgtb
+ mv $@ $@.rootfs
+ cp $(PKGTB_ITS) $@.its
+ sed -i "s=\$${bootfs}=$(KDIR)/bootfs-generic.itb=" $@.its
+ sed -i "s=\$${rootfs}=$@.rootfs=" $@.its
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@
+endef
+
define Device/Default
KERNEL := kernel-bin | bcm4908lzma | bcm4908kernel
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)