aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-10-12 12:54:30 +0200
committerFelix Fietkau <nbd@nbd.name>2022-11-09 20:44:28 +0100
commita06e023b4e124dad2b2ddf3db87cb804b7043b26 (patch)
tree64a3dfcbc4ae2692c2670f37392e7955dc5d8c56 /target/linux/bcm47xx
parentf753316f4aa4764e80c4dbf6f2cc88922052da1e (diff)
downloadupstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.gz
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.bz2
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.zip
mac80211: remove old legacy legacy drivers
Get rid of drivers that are either limited to 802.11b/g or don't even support cfg80211/mac80211. Most of these are either limited to boards that we don't even support anymore because of firmware size, or were only used for custom hacks by a really small number of users in the past. Let's get rid of those to reduce the maintenance effort and the number of useless packages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/bcm47xx')
-rw-r--r--target/linux/bcm47xx/generic/profiles/100-Broadcom-b43.mk6
-rw-r--r--target/linux/bcm47xx/generic/profiles/200-Broadcom-b44-b43.mk4
-rw-r--r--target/linux/bcm47xx/image/legacy.mk12
-rw-r--r--target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk4
4 files changed, 13 insertions, 13 deletions
diff --git a/target/linux/bcm47xx/generic/profiles/100-Broadcom-b43.mk b/target/linux/bcm47xx/generic/profiles/100-Broadcom-b43.mk
index 8ff95b4dd9..a6c14cb33c 100644
--- a/target/linux/bcm47xx/generic/profiles/100-Broadcom-b43.mk
+++ b/target/linux/bcm47xx/generic/profiles/100-Broadcom-b43.mk
@@ -4,13 +4,13 @@
define Profile/Broadcom-b43
NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
- PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-b43 kmod-b43legacy
+ PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-b43
endef
define Profile/Broadcom-b43/Description
Package set compatible with hardware any Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
- b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and b44,
+ tg3 or bgmac Ethernet driver.
endef
$(eval $(call Profile,Broadcom-b43))
diff --git a/target/linux/bcm47xx/generic/profiles/200-Broadcom-b44-b43.mk b/target/linux/bcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
index 0231bff642..a1f8a0efb3 100644
--- a/target/linux/bcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
+++ b/target/linux/bcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
@@ -4,13 +4,13 @@
define Profile/Broadcom-b44-b43
NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (b43, default)
- PACKAGES:=kmod-b44 kmod-b43 kmod-b43legacy
+ PACKAGES:=kmod-b44 kmod-b43
endef
define Profile/Broadcom-b44-b43/Description
Package set compatible with hardware older Broadcom BCM47xx or BCM535x
SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
- b43legacy drivers and b44 Ethernet driver.
+ b44 Ethernet driver.
endef
$(eval $(call Profile,Broadcom-b44-b43))
diff --git a/target/linux/bcm47xx/image/legacy.mk b/target/linux/bcm47xx/image/legacy.mk
index 4538813b91..448c5206f4 100644
--- a/target/linux/bcm47xx/image/legacy.mk
+++ b/target/linux/bcm47xx/image/legacy.mk
@@ -4,7 +4,7 @@
define Device/asus_wl-300g
DEVICE_MODEL := WL-300g
- DEVICE_PACKAGES := kmod-b43 kmod-b43legacy
+ DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "WL300g "
endef
@@ -78,7 +78,7 @@ TARGET_DEVICES += asus_wl-550ge
define Device/asus_wl-hdd25
DEVICE_MODEL := WL-HDD25
- DEVICE_PACKAGES := kmod-b43 kmod-b43legacy $(USB1_PACKAGES)
+ DEVICE_PACKAGES := kmod-b43 $(USB1_PACKAGES)
$(Device/asus)
PRODUCTID := "WLHDD "
endef
@@ -145,7 +145,7 @@ TARGET_DEVICES += linksys_wrt54g3gv2-vf
define Device/linksys_wrt54g
DEVICE_MODEL := WRT54G
- DEVICE_PACKAGES := kmod-b43 kmod-b43legacy
+ DEVICE_PACKAGES := kmod-b43
$(Device/linksys)
DEVICE_ID := W54G
VERSION := 4.71.1
@@ -218,7 +218,7 @@ TARGET_DEVICES += linksys_wrt300n-v1
define Device/motorola_wa840g
DEVICE_MODEL := WA840G
- DEVICE_PACKAGES := kmod-b43 kmod-b43legacy
+ DEVICE_PACKAGES := kmod-b43
$(Device/motorola)
MOTOROLA_DEVICE := 2
endef
@@ -226,7 +226,7 @@ TARGET_DEVICES += motorola_wa840g
define Device/motorola_we800g
DEVICE_MODEL := WE800G
- DEVICE_PACKAGES := kmod-b43 kmod-b43legacy
+ DEVICE_PACKAGES := kmod-b43
$(Device/motorola)
MOTOROLA_DEVICE := 3
endef
@@ -234,7 +234,7 @@ TARGET_DEVICES += motorola_we800g
define Device/motorola_wr850g
DEVICE_MODEL := WR850G
- DEVICE_PACKAGES := kmod-b43 kmod-b43legacy
+ DEVICE_PACKAGES := kmod-b43
$(Device/motorola)
MOTOROLA_DEVICE := 1
endef
diff --git a/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk
index c54f11bb89..691513728c 100644
--- a/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk
+++ b/target/linux/bcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -4,13 +4,13 @@
define Profile/Broadcom-b43
NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
- PACKAGES:=kmod-b43 kmod-b43legacy
+ PACKAGES:=kmod-b43
endef
define Profile/Broadcom-b43/Description
Package set compatible with hardware any Broadcom BCM47xx or BCM535x
SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
- b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+ b44, tg3 or bgmac Ethernet driver.
endef
$(eval $(call Profile,Broadcom-b43))