aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-05-19 18:06:15 +0200
committerFelix Baumann <felix.bau@gmx.de>2023-05-21 01:07:51 +0200
commit3f297be1ed49351282f26462a7aa6e03036a1ffc (patch)
treef7731d43c9b9cf771b5627c84be2dae360fec5f2 /target/linux/bcm47xx
parent09d0643c188f0d08910e490b945f884dfdd866f2 (diff)
downloadupstream-3f297be1ed49351282f26462a7aa6e03036a1ffc.tar.gz
upstream-3f297be1ed49351282f26462a7aa6e03036a1ffc.tar.bz2
upstream-3f297be1ed49351282f26462a7aa6e03036a1ffc.zip
treewide: Disable building 16M RAM devices
Following deprecation notice[1] in 21.02, disable targets with 16M of RAM [1] https://openwrt.org/supported_devices/864_warning Signed-off-by: Felix Baumann <felix.bau@gmx.de>
Diffstat (limited to 'target/linux/bcm47xx')
-rw-r--r--target/linux/bcm47xx/image/legacy.mk25
-rw-r--r--target/linux/bcm47xx/image/mips74k.mk4
2 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/bcm47xx/image/legacy.mk b/target/linux/bcm47xx/image/legacy.mk
index 448c5206f4..4c37a4505c 100644
--- a/target/linux/bcm47xx/image/legacy.mk
+++ b/target/linux/bcm47xx/image/legacy.mk
@@ -7,6 +7,7 @@ define Device/asus_wl-300g
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "WL300g "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-300g
@@ -15,6 +16,7 @@ define Device/asus_wl-320gp
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "WL320gP "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-320gp
@@ -23,6 +25,7 @@ define Device/asus_wl-330ge
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "WL-330gE "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-330ge
@@ -31,6 +34,7 @@ define Device/asus_wl-500gd
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := "WL500gx "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-500gd
@@ -40,6 +44,7 @@ define Device/asus_wl-500gp-v1
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := "WL500gp "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-500gp-v1
@@ -49,6 +54,7 @@ define Device/asus_wl-500gp-v2
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := "WL500gpv2 "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-500gp-v2
@@ -65,6 +71,7 @@ define Device/asus_wl-520gu
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := "WL520gu "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-520gu
@@ -73,6 +80,7 @@ define Device/asus_wl-550ge
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "WL550gE "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-550ge
@@ -81,6 +89,7 @@ define Device/asus_wl-hdd25
DEVICE_PACKAGES := kmod-b43 $(USB1_PACKAGES)
$(Device/asus)
PRODUCTID := "WLHDD "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_wl-hdd25
@@ -99,6 +108,7 @@ define Device/edimax_ps1208-mfg
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
IMAGES := bin
IMAGE/bin := append-rootfs | trx-with-loader | edimax-bin
+ DEFAULT := n
endef
TARGET_DEVICES += edimax_ps1208-mfg
@@ -118,6 +128,7 @@ define Device/linksys_wrt54g3g
$(Device/linksys)
DEVICE_ID := W54F
VERSION := 2.20.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt54g3g
@@ -126,6 +137,7 @@ define Device/linksys_wrt54g3g-em
$(Device/linksys)
DEVICE_ID := W3GN
VERSION := 2.20.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt54g3g-em
@@ -140,6 +152,7 @@ define Device/linksys_wrt54g3gv2-vf
DEVICE_ID := 3G2V
VERSION := 3.00.24
SERIAL := 6
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt54g3gv2-vf
@@ -149,6 +162,7 @@ define Device/linksys_wrt54g
$(Device/linksys)
DEVICE_ID := W54G
VERSION := 4.71.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt54g
@@ -163,6 +177,7 @@ define Device/linksys_wrt54gs
FILESYSTEMS := $(FS_128K)
DEVICE_ID := W54S
VERSION := 4.80.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt54gs
@@ -173,6 +188,7 @@ define Device/linksys_wrt54gs-v4
$(Device/linksys)
DEVICE_ID := W54s
VERSION := 1.09.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt54gs-v4
@@ -183,6 +199,7 @@ define Device/linksys_wrtsl54gs
FILESYSTEMS := $(FS_128K)
DEVICE_ID := W54U
VERSION := 2.08.1
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrtsl54gs
@@ -192,6 +209,7 @@ define Device/linksys_wrt150n
$(Device/linksys)
DEVICE_ID := N150
VERSION := 1.51.3
+ DEFAULT := n
endef
TARGET_DEVICES += linksys_wrt150n
@@ -221,6 +239,7 @@ define Device/motorola_wa840g
DEVICE_PACKAGES := kmod-b43
$(Device/motorola)
MOTOROLA_DEVICE := 2
+ DEFAULT := n
endef
TARGET_DEVICES += motorola_wa840g
@@ -229,6 +248,7 @@ define Device/motorola_we800g
DEVICE_PACKAGES := kmod-b43
$(Device/motorola)
MOTOROLA_DEVICE := 3
+ DEFAULT := n
endef
TARGET_DEVICES += motorola_we800g
@@ -237,6 +257,7 @@ define Device/motorola_wr850g
DEVICE_PACKAGES := kmod-b43
$(Device/motorola)
MOTOROLA_DEVICE := 1
+ DEFAULT := n
endef
TARGET_DEVICES += motorola_wr850g
@@ -247,6 +268,7 @@ define Device/netgear_wgr614-v8
$(Device/netgear)
NETGEAR_BOARD_ID := U12H072T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wgr614-v8
@@ -257,6 +279,7 @@ define Device/netgear_wgt634u
FILESYSTEMS := $(FS_128K)
IMAGES := bin
IMAGE/bin := append-rootfs | trx-with-loader | prepend-with-elf
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wgt634u
@@ -267,6 +290,7 @@ define Device/netgear_wndr3300-v1
$(Device/netgear)
NETGEAR_BOARD_ID := U12H093T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wndr3300-v1
@@ -277,6 +301,7 @@ define Device/netgear_wnr834b-v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H081T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr834b-v2
diff --git a/target/linux/bcm47xx/image/mips74k.mk b/target/linux/bcm47xx/image/mips74k.mk
index 7e65821a55..4478374f16 100644
--- a/target/linux/bcm47xx/image/mips74k.mk
+++ b/target/linux/bcm47xx/image/mips74k.mk
@@ -24,6 +24,7 @@ define Device/asus_rt-n10
DEVICE_PACKAGES := kmod-b43
$(Device/asus)
PRODUCTID := "RT-N10 "
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n10
@@ -323,6 +324,7 @@ define Device/netgear_wgr614-v10-na
$(Device/netgear)
NETGEAR_BOARD_ID := U12H139T01_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wgr614-v10-na
@@ -332,6 +334,7 @@ define Device/netgear_wgr614-v10
$(Device/netgear)
NETGEAR_BOARD_ID := U12H139T01_NETGEAR
NETGEAR_REGION := 1
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wgr614-v10
@@ -420,6 +423,7 @@ define Device/netgear_wnr1000-v3
$(Device/netgear)
NETGEAR_BOARD_ID := U12H139T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr1000-v3