aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm47xx/image/generic.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-07 13:12:43 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-12 19:01:47 +0200
commit1226113fe2b9aadf120bb8f771938665028f632c (patch)
treef60cd07b7f20b7611682664aa5f82fe445c0cbd3 /target/linux/bcm47xx/image/generic.mk
parentfeb55fd3ecfc3d02f212c1b2f1af748e3233ecd5 (diff)
downloadupstream-1226113fe2b9aadf120bb8f771938665028f632c.tar.gz
upstream-1226113fe2b9aadf120bb8f771938665028f632c.tar.bz2
upstream-1226113fe2b9aadf120bb8f771938665028f632c.zip
bcm47xx: move device definitions to subfiles
With several subtargets, the image/Makefile becomes crowded after a while. Many targets have moved their device definitions to $subtarget.mk files to have them more organized, let's do this here as well. Cc: Rafał Miłecki <rafal@milecki.pl> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm47xx/image/generic.mk')
-rw-r--r--target/linux/bcm47xx/image/generic.mk72
1 files changed, 72 insertions, 0 deletions
diff --git a/target/linux/bcm47xx/image/generic.mk b/target/linux/bcm47xx/image/generic.mk
new file mode 100644
index 0000000000..e5ae952137
--- /dev/null
+++ b/target/linux/bcm47xx/image/generic.mk
@@ -0,0 +1,72 @@
+#################################################
+# Subtarget generic
+#################################################
+
+ # BCM4705 with tg3
+define Device/linksys-wrt300n-v1.1
+ DEVICE_MODEL := WRT300N
+ DEVICE_VARIANT := v1.1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43
+ $(Device/linksys)
+ DEVICE_ID := EWC2
+ VERSION := 1.51.2
+endef
+TARGET_DEVICES += linksys-wrt300n-v1.1
+
+define Device/linksys-wrt310n-v1
+ DEVICE_MODEL := WRT310N
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43
+ $(Device/linksys)
+ DEVICE_ID := 310N
+ VERSION := 1.0.10
+endef
+TARGET_DEVICES += linksys-wrt310n-v1
+
+define Device/linksys-wrt350n-v1
+ DEVICE_MODEL := WRT350N
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43 $(USB2_PACKAGES)
+ $(Device/linksys)
+ DEVICE_ID := EWCG
+ VERSION := 1.04.1
+endef
+TARGET_DEVICES += linksys-wrt350n-v1
+
+define Device/linksys-wrt610n-v1
+ DEVICE_MODEL := WRT610N
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-tg3 kmod-b43 $(USB2_PACKAGES)
+ $(Device/linksys)
+ DEVICE_ID := 610N
+ VERSION := 1.0.1
+endef
+TARGET_DEVICES += linksys-wrt610n-v1
+
+ # BCMA SoC with SSB WiFi
+define Device/linksys-wrt610n-v2
+ DEVICE_MODEL := WRT610N
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := kmod-bgmac kmod-b43 $(USB2_PACKAGES)
+ $(Device/linksys)
+ DEVICE_ID := 610N
+ VERSION := 2.0.0
+endef
+TARGET_DEVICES += linksys-wrt610n-v2
+
+define Device/linksys-e3000-v1
+ DEVICE_MODEL := E3000
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-bgmac kmod-b43 $(USB2_PACKAGES)
+ $(Device/linksys)
+ DEVICE_ID := 61XN
+ VERSION := 1.0.3
+endef
+TARGET_DEVICES += linksys-e3000-v1
+
+# generic has Ethernet drivers as modules so overwrite standard image
+define Device/standard
+ DEVICE_TITLE := Image with LZMA loader and LZMA compressed kernel
+ DEVICE_PACKAGES := kmod-b44 kmod-bgmac kmod-tg3
+endef
+TARGET_DEVICES += standard