aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.10
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2022-10-30 08:32:36 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-01 13:56:11 +0100
commit0ff3adfa11a7b845a182ab8c37c1d363302b9991 (patch)
tree461d186d4b70ebc9a4f4a4334a31284b22bc33f8 /target/linux/bcm27xx/patches-5.10
parent0abcea19d7a3760d36c4bfb5158b807707eecabd (diff)
downloadupstream-0ff3adfa11a7b845a182ab8c37c1d363302b9991.tar.gz
upstream-0ff3adfa11a7b845a182ab8c37c1d363302b9991.tar.bz2
upstream-0ff3adfa11a7b845a182ab8c37c1d363302b9991.zip
kernel: bump 5.10 to 5.10.152
All patches automatically rebased. Signed-off-by: John Audia <therealgraysky@proton.me> [Add CONFIG_ARM64_ERRATUM_1742098 to config] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 52400e167d83bd0bfc40394f9383529212b545ad)
Diffstat (limited to 'target/linux/bcm27xx/patches-5.10')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch16
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0162-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch2
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0192-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch2
3 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch b/target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch
index 0644dd4274..cc56cff24f 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch
@@ -221,7 +221,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
static inline int mmc_blk_part_switch(struct mmc_card *card,
unsigned int part_type);
static void mmc_blk_rw_rq_prep(struct mmc_queue_req *mqrq,
-@@ -2896,6 +2903,7 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2901,6 +2908,7 @@ static int mmc_blk_probe(struct mmc_card
{
struct mmc_blk_data *md, *part_md;
char cap_str[10];
@@ -229,7 +229,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
/*
* Check that the card supports the command class(es) we need.
-@@ -2903,7 +2911,16 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2908,7 +2916,16 @@ static int mmc_blk_probe(struct mmc_card
if (!(card->csd.cmdclass & CCC_BLOCK_READ))
return -ENODEV;
@@ -247,7 +247,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
card->complete_wq = alloc_workqueue("mmc_complete",
WQ_MEM_RECLAIM | WQ_HIGHPRI, 0);
-@@ -2918,9 +2935,14 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2923,9 +2940,14 @@ static int mmc_blk_probe(struct mmc_card
string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2,
cap_str, sizeof(cap_str));
@@ -278,9 +278,9 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
}
--- a/drivers/mmc/core/quirks.h
+++ b/drivers/mmc/core/quirks.h
-@@ -99,6 +99,14 @@ static const struct mmc_fixup __maybe_un
- MMC_FIXUP("V10016", CID_MANFID_KINGSTON, CID_OEMID_ANY, add_quirk_mmc,
- MMC_QUIRK_TRIM_BROKEN),
+@@ -105,6 +105,14 @@ static const struct mmc_fixup __maybe_un
+ MMC_FIXUP(CID_NAME_ANY, CID_MANFID_SANDISK_SD, 0x5344, add_quirk_sd,
+ MMC_QUIRK_BROKEN_SD_DISCARD),
+ /*
+ * On some Kingston SD cards, multiple erases of less than 64
@@ -1922,9 +1922,9 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
+MODULE_AUTHOR("Gellert Weisz");
--- a/include/linux/mmc/card.h
+++ b/include/linux/mmc/card.h
-@@ -271,6 +271,8 @@ struct mmc_card {
- #define MMC_QUIRK_TRIM_BROKEN (1<<12) /* Skip trim */
+@@ -272,6 +272,8 @@ struct mmc_card {
#define MMC_QUIRK_BROKEN_HPI (1<<13) /* Disable broken HPI support */
+ #define MMC_QUIRK_BROKEN_SD_DISCARD (1<<14) /* Disable broken SD discard support */
+#define MMC_QUIRK_ERASE_BROKEN (1<<31) /* Skip erase */
+
diff --git a/target/linux/bcm27xx/patches-5.10/950-0162-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch b/target/linux/bcm27xx/patches-5.10/950-0162-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
index 9c8acd8b25..0506bc26a8 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0162-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0162-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
--- a/Makefile
+++ b/Makefile
-@@ -1367,6 +1367,9 @@ ifneq ($(dtstree),)
+@@ -1369,6 +1369,9 @@ ifneq ($(dtstree),)
%.dtb: include/config/kernel.release scripts_dtc
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
diff --git a/target/linux/bcm27xx/patches-5.10/950-0192-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch b/target/linux/bcm27xx/patches-5.10/950-0192-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch
index a1f97539a3..1a961ab45b 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0192-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0192-Kbuild-Allow-.dtbo-overlays-to-be-built-adjust.patch
@@ -15,7 +15,7 @@ Signed-off-by: Nataliya Korovkina <malus.brandywine@gmail.com>
--- a/Makefile
+++ b/Makefile
-@@ -1367,7 +1367,7 @@ ifneq ($(dtstree),)
+@@ -1369,7 +1369,7 @@ ifneq ($(dtstree),)
%.dtb: include/config/kernel.release scripts_dtc
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@