aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-17 16:39:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-17 16:39:47 +0000
commitb2d76e1e0591a81206f1865bbbe8cf273486f8e2 (patch)
treef343b57cda5de90f6d73d761ad4cba3ca70d177f /target/linux/au1000
parent81a84b03ea82616015a1803691d3acf6575e109d (diff)
downloadupstream-b2d76e1e0591a81206f1865bbbe8cf273486f8e2.tar.gz
upstream-b2d76e1e0591a81206f1865bbbe8cf273486f8e2.tar.bz2
upstream-b2d76e1e0591a81206f1865bbbe8cf273486f8e2.zip
au1000: fix InternetBox idsel and remove broken flag
The following patch is necessary for the InternetBox (Surfbox) board-specific idsel to work with newer kernels. Acutally I don't exactly understand why this was not necessary before, but without the udelay, the MiniPCI adapter in slot 3 is not detected and set up correctly. Also remove platform broken flag, it works. Signed-off-by: Bruno Randolf <br1@einfach.org> SVN-Revision: 32766
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/au1000/patches-3.3/004-pci-idsel-cb.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index 5871beb427..2405ece4e5 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
-FEATURES:=jffs2 usb pci broken
+FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
diff --git a/target/linux/au1000/patches-3.3/004-pci-idsel-cb.patch b/target/linux/au1000/patches-3.3/004-pci-idsel-cb.patch
new file mode 100644
index 0000000000..6b36032207
--- /dev/null
+++ b/target/linux/au1000/patches-3.3/004-pci-idsel-cb.patch
@@ -0,0 +1,12 @@
+--- a/arch/mips/alchemy/board-mtx1.c 2012-06-11 22:02:34.686604093 +0100
++++ b/arch/mips/alchemy/board-mtx1.c 2012-06-11 22:04:23.375143044 +0100
+@@ -228,6 +228,9 @@
+ * adapter on the mtx-1 "singleboard" variant. It triggers a custom
+ * logic chip connected to EXT_IO3 (GPIO1) to suppress IDSEL signals.
+ */
++
++ udelay(1);
++
+ if (assert && devsel != 0)
+ /* Suppress signal to Cardbus */
+ alchemy_gpio_set_value(1, 0); /* set EXT_IO3 OFF */