aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-19 06:20:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-19 06:20:55 +0000
commit2665d7f09e8f1b23744fd19243b2747f654e4656 (patch)
tree76e80a9a7acecc3dd2b4c9129323a3311284745f /target/linux/au1000-2.6/Makefile
parentae439d6682f238bcff9c23a88aabc7b3689c0db5 (diff)
downloadupstream-2665d7f09e8f1b23744fd19243b2747f654e4656.tar.gz
upstream-2665d7f09e8f1b23744fd19243b2747f654e4656.tar.bz2
upstream-2665d7f09e8f1b23744fd19243b2747f654e4656.zip
cleanup/rewrite of the kernel build process
SVN-Revision: 5226
Diffstat (limited to 'target/linux/au1000-2.6/Makefile')
-rw-r--r--target/linux/au1000-2.6/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/target/linux/au1000-2.6/Makefile b/target/linux/au1000-2.6/Makefile
index ca85b73bca..62d9acbdd1 100644
--- a/target/linux/au1000-2.6/Makefile
+++ b/target/linux/au1000-2.6/Makefile
@@ -10,17 +10,13 @@ LINUX_VERSION:=2.6.17
LINUX_RELEASE:=1
LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-include ./config
include $(INCLUDE_DIR)/kernel-build.mk
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
- [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
- [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
- @$(CP) config $(LINUX_DIR)/.config
- touch $@
-
-$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/vmlinux
+define Kernel/BuildImage
+ $(call Kernel/BuildImage/Default)
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
+endef
+
+$(eval $(call BuildKernel))
-compile: $(LINUX_BUILD_DIR)/zImage.flash.srec