aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/patches/100-board.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-16 09:23:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-16 09:23:15 +0000
commitb7e5e78ae6fd8a08cb01a7a7c8f23f297459db91 (patch)
treea876d1a91d12fc5c15d05d7ec65dbf21430bcacc /target/linux/atheros-2.6/patches/100-board.patch
parentc55df2a7ed31000b9e3b52b32cf7079f1f5f8cec (diff)
downloadupstream-b7e5e78ae6fd8a08cb01a7a7c8f23f297459db91.tar.gz
upstream-b7e5e78ae6fd8a08cb01a7a7c8f23f297459db91.tar.bz2
upstream-b7e5e78ae6fd8a08cb01a7a7c8f23f297459db91.zip
major cleanup of the ar531x code, improved hardware detection and support for multiple ethernet interfaces
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros-2.6/patches/100-board.patch')
-rw-r--r--target/linux/atheros-2.6/patches/100-board.patch11
1 files changed, 8 insertions, 3 deletions
diff --git a/target/linux/atheros-2.6/patches/100-board.patch b/target/linux/atheros-2.6/patches/100-board.patch
index a137d15d20..f04953a1e3 100644
--- a/target/linux/atheros-2.6/patches/100-board.patch
+++ b/target/linux/atheros-2.6/patches/100-board.patch
@@ -46,7 +46,7 @@ diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h
--- linux.old/include/asm-mips/bootinfo.h 2007-02-02 23:55:52.913446632 +0100
+++ linux.dev/include/asm-mips/bootinfo.h 2007-02-03 17:51:02.531494032 +0100
-@@ -212,6 +212,13 @@
+@@ -212,6 +212,18 @@
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
@@ -54,8 +54,13 @@ diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/booti
+ * Valid machtype for group ATHEROS
+ */
+#define MACH_GROUP_ATHEROS 26
-+#define MACH_ATHEROS_AR5312 0 /* Atheros AR5312, AR2312/3/4 */
-+#define MACH_ATHEROS_AR5315 1 /* Atheros AR2315/6/7/8 */
++#define MACH_ATHEROS_AR5312 0
++#define MACH_ATHEROS_AR2312 1
++#define MACH_ATHEROS_AR2313 2
++#define MACH_ATHEROS_AR2315 3
++#define MACH_ATHEROS_AR2316 4
++#define MACH_ATHEROS_AR2317 5
++#define MACH_ATHEROS_AR2318 6
+
#define CL_SIZE COMMAND_LINE_SIZE