aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
commitc6bc77ea365704f3f5c79d64aed069792a4e95b1 (patch)
tree28c9265495e6ad751fcae0d27a040b222ff2a215 /target/linux/atheros-2.6/image/Makefile
parent9882253827b16579bbd317f6e8c0deb75b0ca0f3 (diff)
downloadupstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.gz
upstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.bz2
upstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.zip
build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail/openwrt-devel/2007-August/001159.html
SVN-Revision: 8362
Diffstat (limited to 'target/linux/atheros-2.6/image/Makefile')
-rw-r--r--target/linux/atheros-2.6/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index 1d32a4bd46..5cfa774041 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
- $(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.lzma bs=65536 conv=sync
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz bs=65536 conv=sync
endef