aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-05-20 08:37:45 +0200
committerFelix Baumann <felix.bau@gmx.de>2023-05-21 01:08:22 +0200
commitf5cb556d4f70e7aac428857fe782b58ece0cf188 (patch)
tree5cb0a1675cfec759d97837e3e9fdad955879f21c /target/linux/ath79
parent3f297be1ed49351282f26462a7aa6e03036a1ffc (diff)
downloadupstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.gz
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.bz2
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.zip
treewide: Disable building 32M RAM devices
Following deprecation notice[1] in 21.02, disable targets with 32M of RAM [1] https://openwrt.org/supported_devices/864_warning Signed-off-by: Felix Baumann <felix.bau@gmx.de>
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk6
-rw-r--r--target/linux/ath79/image/generic.mk2
-rw-r--r--target/linux/ath79/image/tiny-ubnt.mk7
-rw-r--r--target/linux/ath79/image/tiny.mk1
4 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 8336189293..cfabc89b8d 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -707,6 +707,7 @@ define Device/tplink_tl-wr1043nd-v1
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-switch-rtl8366rb
TPLINK_HWID := 0x10430001
SUPPORTED_DEVICES += tl-wr1043nd
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr1043nd-v1
@@ -789,6 +790,7 @@ define Device/tplink_tl-wr710n-v1
DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x07100001
SUPPORTED_DEVICES += tl-wr710n
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr710n-v1
@@ -801,6 +803,7 @@ define Device/tplink_tl-wr710n-v2.1
TPLINK_HWID := 0x07100002
TPLINK_HWREV := 0x2
SUPPORTED_DEVICES += tl-wr710n
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr710n-v2.1
@@ -822,6 +825,7 @@ define Device/tplink_tl-wr810n-v2
DEVICE_VARIANT := v2
TPLINK_HWID := 0x8100002
SUPPORTED_DEVICES += tl-wr810n-v2
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr810n-v2
@@ -851,6 +855,7 @@ define Device/tplink_tl-wr842n-v1
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x8420001
SUPPORTED_DEVICES += tl-mr3420
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr842n-v1
@@ -862,6 +867,7 @@ define Device/tplink_tl-wr842n-v2
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x8420002
SUPPORTED_DEVICES += tl-wr842n-v2
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr842n-v2
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d4a419501c..f8969a919c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2924,6 +2924,7 @@ define Device/wd_mynet-wifi-rangeextender
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | cybertan-trx | \
addpattern | append-metadata
SUPPORTED_DEVICES += mynet-rext
+ DEFAULT := n
endef
TARGET_DEVICES += wd_mynet-wifi-rangeextender
@@ -3014,6 +3015,7 @@ define Device/ziking_cpe46b
DEVICE_MODEL := CPE46B
IMAGE_SIZE := 8000k
DEVICE_PACKAGES := kmod-i2c-gpio
+ DEFAULT := n
endef
TARGET_DEVICES += ziking_cpe46b
diff --git a/target/linux/ath79/image/tiny-ubnt.mk b/target/linux/ath79/image/tiny-ubnt.mk
index 805d193d45..0733371441 100644
--- a/target/linux/ath79/image/tiny-ubnt.mk
+++ b/target/linux/ath79/image/tiny-ubnt.mk
@@ -5,6 +5,7 @@ define Device/ubnt_airrouter
SOC := ar7241
DEVICE_MODEL := AirRouter
SUPPORTED_DEVICES += airrouter
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_airrouter
@@ -14,6 +15,7 @@ define Device/ubnt_nanobridge-m
DEVICE_MODEL := NanoBridge M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_nanobridge-m
@@ -24,6 +26,7 @@ define Device/ubnt_bullet-m-ar7240
DEVICE_VARIANT := XM (AR7240)
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_bullet-m-ar7240
@@ -34,6 +37,7 @@ define Device/ubnt_bullet-m-ar7241
DEVICE_VARIANT := XM (AR7241)
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_bullet-m-ar7241
@@ -43,6 +47,7 @@ define Device/ubnt_picostation-m
DEVICE_MODEL := Picostation M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_picostation-m
@@ -52,6 +57,7 @@ define Device/ubnt_nanostation-m
DEVICE_MODEL := Nanostation M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += nanostation-m
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_nanostation-m
@@ -61,6 +67,7 @@ define Device/ubnt_nanostation-loco-m
DEVICE_MODEL := Nanostation Loco M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
+ DEFAULT := n
endef
TARGET_DEVICES += ubnt_nanostation-loco-m
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 0f355ef914..6baa3afff7 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -76,5 +76,6 @@ define Device/pqi_air-pen
DEVICE_PACKAGES := kmod-usb-chipidea2
IMAGE_SIZE := 7680k
SUPPORTED_DEVICES += pqi-air-pen
+ DEFAULT := n
endef
TARGET_DEVICES += pqi_air-pen