aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2020-03-12 11:37:10 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 23:17:30 +0200
commite210fe91b186ba5b229fd64d165a631810d60dac (patch)
tree08bafb66e4939c7a39db014e558e2f539f2e7996 /target/linux/ath79/image
parentf0435d53439bdf2a329d2145e40b8e8e65508754 (diff)
downloadupstream-e210fe91b186ba5b229fd64d165a631810d60dac.tar.gz
upstream-e210fe91b186ba5b229fd64d165a631810d60dac.tar.bz2
upstream-e210fe91b186ba5b229fd64d165a631810d60dac.zip
ath79: add support for Ubiquiti PowerBeam 5AC Gen2
The Ubiquiti PowerBeam 5AC Gen 2 (PBE-5AC-Gen2) is an outdoor 802.11ac 5 GHz bridge with a radio feed and a dish antenna. The device is hardware-compatible with the LiteBeam AC Gen2, plus the 4 extra LEDs. Specifications: - SoC: Qualcomm Atheros AR9342 rev 2 - RAM: 64 MB DDR2 - Flash: 16 MB SPI NOR (mx25l12805d) - Ethernet: 1x 10/100/1000 Mbps Atheros 8035, 24 Vdc PoE-in - WiFi 5 GHz: QCA988x HW2.0 Ubiquiti target 0x4100016c chip_id 0x043222ff - WiFi 2.4 GHz: Atheros AR9340 (SoC-based) - Buttons: 1x (reset) - LEDs: 1x power, 1x Ethernet, 4x RSSI via GPIO. All blue. - UART: not tested Installation from stock airOS firmware: - Follow instructions for WA-type Ubiquiti devices on OpenWrt wiki Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net> [changed device name in commit title] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 7ad54083b6..d056ab6783 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -243,6 +243,14 @@ define Device/ubnt_picostation-m
endef
TARGET_DEVICES += ubnt_picostation-m
+define Device/ubnt_powerbeam-5ac-gen2
+ $(Device/ubnt-wa)
+ DEVICE_MODEL := PowerBeam 5AC
+ DEVICE_VARIANT := Gen2
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct rssileds
+endef
+TARGET_DEVICES += ubnt_powerbeam-5ac-gen2
+
define Device/ubnt_rocket-m
$(Device/ubnt-xm)
SOC := ar7241