aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2020-09-06 09:52:43 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2020-09-28 01:28:37 +0200
commitc65c306d336418f3b6519693d892148f6e2eb38e (patch)
tree68aee8b3ab90159b5b709071c8ccc28b506b2771 /target/linux/ath79/image
parent77598f19cc08a421f927979b3e85f7f18b8f9648 (diff)
downloadupstream-c65c306d336418f3b6519693d892148f6e2eb38e.tar.gz
upstream-c65c306d336418f3b6519693d892148f6e2eb38e.tar.bz2
upstream-c65c306d336418f3b6519693d892148f6e2eb38e.zip
ath79: add support for Wallys DR531
Wallys DR531 is based on Qualcomm Atheros QCA9531 v2. Support for this device was first introduced in e767980eb8 (ar71xx target). Specifications: - Qualcomm/Atheros QCA9531 v2 - 550/400/200 MHz (CPU/DDR/AHB) - 2x 10/100 Mbps Ethernet - 64 MB of RAM (DDR2) - 8 MB of flash (SPI NOR) - 2T2R 2.4 GHz Wi-Fi, with external PA (SE2576L), up to 30 dBm - 2x MMCX connectors (optional IPEX/U.FL) - mini PCIe connector (PCIe/USB buses and mini SIM slot) - 7x LED, 1x button, 1x optional buzzer - UART, JTAG and LED headers on PCB Flash instruction (do it under U-Boot, using UART): tftpb 0x80060000 openwrt-ath79-...-dr531-squashfs-sysupgrade.bin erase 0x9f050000 +$filesize cp.b $fileaddr 0x9f050000 $filesize setenv bootcmd "bootm 0x9f050000" saveenv && reset Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 54e927cb8e..e8bc74178f 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1517,6 +1517,16 @@ define Device/trendnet_tew-823dru
endef
TARGET_DEVICES += trendnet_tew-823dru
+define Device/wallys_dr531
+ SOC := qca9531
+ DEVICE_VENDOR := Wallys
+ DEVICE_MODEL := DR531
+ DEVICE_PACKAGES := kmod-usb2 rssileds
+ IMAGE_SIZE := 7808k
+ SUPPORTED_DEVICES += dr531
+endef
+TARGET_DEVICES += wallys_dr531
+
define Device/wd_mynet-n750
$(Device/seama)
SOC := ar9344