aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAndrey Bondar <a.bondar@8devices.com>2020-07-08 13:51:34 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-08 16:07:05 +0200
commitba59021d64d52a5ec3e75b9701d65f940c33a670 (patch)
treec1742044f29de15911092706f5490acb2d52fd97 /target/linux/ath79/image
parent667fbb8151c7348283985f28c43aeb848f948350 (diff)
downloadupstream-ba59021d64d52a5ec3e75b9701d65f940c33a670.tar.gz
upstream-ba59021d64d52a5ec3e75b9701d65f940c33a670.tar.bz2
upstream-ba59021d64d52a5ec3e75b9701d65f940c33a670.zip
ath79: add support for 8devices Lima board
Specification: • 650/600/216 MHz (CPU/DDR/AHB) • 64 MB of RAM (DDR2) • 32 MB of FLASH • 2T2R 2.4 GHz • 2x 10/100 Mbps Ethernet • 1x USB 2.0 Host socket • 1x miniPCIe slot • UART for serial console • 14x GPIO Flash instructions: Upgrading from ar71xx target: • Upload image into the board: scp openwrt-ath79-generic-8dev_lima-squashfs-sysupgrade.bin root@192.168.1.1/tmp/ • Run sysupgrade sysupgrade -F /tmp/openwrt-ath79-generic-8dev_lima-squashfs-sysupgrade.bin Upgrading from u-boot: • Set up tftp server with openwrt-ath79-generic-8dev_lima-initramfs-kernel.bin • Go to u-boot (reboot and press ESC when prompted) • Set TFTP server IP setenv serverip 192.168.1.254 • Set device ip from the same subnet setenv ipaddr 192.168.1.1 • Copy new firmware to board tftpboot 0x82000000 initramfs.bin • Boot OpenWRT bootm 0x82000000 • Upload image openwrt-ath79-generic-8dev_lima-squashfs-sysupgrade.bin into the board • Run sysupgrade. Signed-off-by: Andrey Bondar <a.bondar@8devices.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 0e7efa32af..d8cac425e8 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -152,6 +152,16 @@ define Device/8dev_carambola2
endef
TARGET_DEVICES += 8dev_carambola2
+define Device/8dev_lima
+ SOC := qca9531
+ DEVICE_VENDOR := 8devices
+ DEVICE_MODEL := Lima
+ DEVICE_PACKAGES := kmod-usb2
+ IMAGE_SIZE := 15616k
+ SUPPORTED_DEVICES += lima
+endef
+TARGET_DEVICES += 8dev_lima
+
define Device/adtran_bsap1880
SOC := ar7161
DEVICE_VENDOR := Adtran/Bluesocket