aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorJohann Neuhauser <johann@it-neuhauser.de>2018-05-18 18:06:03 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:53:15 +0200
commita7e1e919afa9659f66dada5e69d1b162f447ced7 (patch)
tree18d949d909bca4f07d74df18bacf72ba92d70962 /target/linux/ath79/image
parentfaf0a460c4b8d77bed270156a4454b964a551c95 (diff)
downloadupstream-a7e1e919afa9659f66dada5e69d1b162f447ced7.tar.gz
upstream-a7e1e919afa9659f66dada5e69d1b162f447ced7.tar.bz2
upstream-a7e1e919afa9659f66dada5e69d1b162f447ced7.zip
ath79: preliminary support for TP-Link WDR3600 / WDR4300 (AR9344)
working: - leds - buttons - lan / wan - usb (hub port 1 + 2) - wifi 5g - sysupgrade - ... not working: - wifi 2g Signed-off-by: Johann Neuhauser <johann@it-neuhauser.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk26
1 files changed, 25 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index dd1a983b7f..a368662cca 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -47,7 +47,7 @@ define Device/tplink
KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v1-header
IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
+ IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata
IMAGE/factory.bin := append-rootfs | mktplinkfw factory
endef
@@ -72,6 +72,12 @@ define Device/tplink-8m
IMAGE_SIZE := 7936k
endef
+define Device/tplink-8mlzma
+$(Device/tplink)
+ TPLINK_FLASHLAYOUT := 8Mlzma
+ IMAGE_SIZE := 7936k
+endef
+
define Device/tl_wr1043nd_v1
$(Device/tplink-8m)
ATH_SOC := ar9132
@@ -81,3 +87,21 @@ define Device/tl_wr1043nd_v1
SUPPORTED_DEVICES := tplink,tl-wr1043nd-v1 tl-wr1043nd
endef
#TARGET_DEVICES += tl_wr1043nd_v1
+
+define Device/tl-wdr3600
+ $(Device/tplink-8mlzma)
+ ATH_SOC := ar9344
+ DEVICE_TITLE := TP-LINK TL-WDR3600
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x36000001
+ SUPPORTED_DEVICES := tplink,tl-wdr3600 tl-wdr3600
+endef
+TARGET_DEVICES += tl-wdr3600
+
+define Device/tl-wdr4300
+ $(Device/tl-wdr3600)
+ DEVICE_TITLE := TP-LINK TL-WDR4300
+ TPLINK_HWID := 0x43000001
+ SUPPORTED_DEVICES := tplink,tl-wdr4300 tl-wdr4300
+endef
+TARGET_DEVICES += tl-wdr4300