aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorChen Minqiang <ptpt52@gmail.com>2020-11-25 01:53:39 +0800
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commita1b5a43fc4b0edda5bbbb4eb0130ba9160dc515b (patch)
tree052be7758db5e87f9e6991a088452eb7306e0dee /target/linux/ath79/image
parent73bdbb3d2025512241061aaf18f7719cf6767452 (diff)
downloadupstream-a1b5a43fc4b0edda5bbbb4eb0130ba9160dc515b.tar.gz
upstream-a1b5a43fc4b0edda5bbbb4eb0130ba9160dc515b.tar.bz2
upstream-a1b5a43fc4b0edda5bbbb4eb0130ba9160dc515b.zip
ath79: add support for GL.iNet GL-USB150
Add support for the ar71xx supported GL.iNet GL-USB150 to ath79. GL.iNet GL-USB150 is an USB dongle WiFi router, based on Atheros AR9331. Specification: - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - Realtek RTL8152B USB to Ethernet bridge (connected with AR9331 PHY4) - 1T1R 2.4 GHz - 2x LED, 1x button - UART header on PCB Flash instruction: Vendor software is based on openwrt so you can flash the sysupgrade image via the vendor GUI or using command line sysupgrade utility. Make sure to not save configuration over reflash as uci settings differ between versions. Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index e44e780e8c..661d4203ed 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1111,6 +1111,15 @@ define Device/glinet_gl-mifi
endef
TARGET_DEVICES += glinet_gl-mifi
+define Device/glinet_gl-usb150
+ SOC := ar9331
+ DEVICE_VENDOR := GL.iNET
+ DEVICE_MODEL := GL-USB150
+ IMAGE_SIZE := 16000k
+ SUPPORTED_DEVICES += gl-usb150
+endef
+TARGET_DEVICES += glinet_gl-usb150
+
define Device/glinet_gl-x750
SOC := qca9531
DEVICE_VENDOR := GL.iNet