aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-10-31 00:05:43 +0800
committerMathias Kresin <dev@kresin.me>2018-12-06 20:26:30 +0100
commit9dd7147f6bce44a49fef594f55b120253baf5556 (patch)
tree63c6b115eedf35d834a0a25f57d1c1dea5f0e16c /target/linux/ath79/image
parente0c55760e6edaa43631245dbfd52986138c353c4 (diff)
downloadupstream-9dd7147f6bce44a49fef594f55b120253baf5556.tar.gz
upstream-9dd7147f6bce44a49fef594f55b120253baf5556.tar.bz2
upstream-9dd7147f6bce44a49fef594f55b120253baf5556.zip
ath79: add support for Winchannel WB2000
WB2000 is a dual-band 11N AP using AR9344. The factory firmware used the original DB120 partition table with a small kernel partition at the end of firmware and the kernel will easily get oversized in the future. Since it has to be flashed using UART I also swapped kernel/rootfs and changed the default load address. Specification: - SoC: Atheros AR9344 - RAM: 128 MB - Flash: 16 MB - Ethernet: 10/100/1000 Mbps (Atheros AR8035) - 2x USB 2.0 - WIFI: AR9344(2G) + AR9382(5G) - RTC: DS1338 Known issue: 5G ath9k led doesn't work due to commit ccab68f. Flash instruction: Set up a TFTP server on your computer and configure static IP. Connect UART (J11 TX/GND/RX) and press any key to enter U-boot shell. 1. Change the default boot command: setenv bootcmd 'bootm 0x9f050000 || bootm 0x9fd50000' saveenv 2. Set your router ipaddr and server ipaddr. e.g.: setenv ipaddr 192.168.1.1 setenv serverip 192.168.1.50 3. Load and flash the firmware: tftp 0x80060000 fw.bin erase 0x9f050000 +$filesize cp.b $fileaddr 0x9f050000 $filesize 4. Reset your router: reset Signed-off-by: Chuanhong Guo <gch981213@gmail.com> [Drop the i2c node unit address. Move the ath9k-leds node out of the spi node, it doesn't belong there. Add the #gpio-cells property to the pci wifi node. All fix dtc compiler warnings] Signed-off-by: Mathias Kresin <dev@kresin.me> merge
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 81cdafdd37..74d185ea63 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -356,3 +356,11 @@ define Device/wd_mynet-wifi-rangeextender
SUPPORTED_DEVICES += mynet-rext
endef
TARGET_DEVICES += wd_mynet-wifi-rangeextender
+
+define Device/winchannel_wb2000
+ ATH_SOC := ar9344
+ DEVICE_TITLE := Winchannel WB2000
+ IMAGE_SIZE := 15872k
+ DEVICE_PACKAGES := kmod-i2c-core kmod-i2c-gpio kmod-rtc-ds1307 kmod-usb2 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += winchannel_wb2000