aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commit5fc28ef47959c1256f2553d507224bb481b08494 (patch)
tree2b84e59d7b658d37c2f648590013638e51ddfb2d /target/linux/ath79/image
parent727eebbad1b9dea91174ea675cb64ea13484f790 (diff)
downloadupstream-5fc28ef47959c1256f2553d507224bb481b08494.tar.gz
upstream-5fc28ef47959c1256f2553d507224bb481b08494.tar.bz2
upstream-5fc28ef47959c1256f2553d507224bb481b08494.zip
ath79: Add support for Plasma Cloud PA300
Device specifications: * Qualcomm/Atheros QCA9533 v2 * 650/600/217 MHz (CPU/DDR/AHB) * 64 MB of RAM * 16 MB of SPI NOR flash (mx25l12805d) - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 2x 10/100 Mbps Ethernet * 2T2R 2.4 GHz Wi-Fi * multi-color LED (controlled via red/green/blue GPIOs) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x fast ethernet - eth0 + Label: Ethernet 1 + 24V passive POE (mode B) + used as WAN interface - eth1 + Label: Ethernet 2 + 802.3af POE + builtin switch port 2 + used as LAN interface * 12-24V 1A DC * internal antennas Flashing instructions: The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the factory image to the u-boot when the device boots up. Signed-off-by: Sven Eckelmann <sven@narfation.org>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 333420c827..935dee75d7 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1579,6 +1579,24 @@ define Device/pisen_wmm003n
endef
TARGET_DEVICES += pisen_wmm003n
+define Device/plasmacloud_pa300-common
+ SOC := qca9533
+ DEVICE_VENDOR := Plasma Cloud
+ DEVICE_PACKAGES := uboot-envtools
+ IMAGE_SIZE := 7168k
+ BLOCKSIZE := 64k
+ IMAGES += factory.bin
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-to $$(BLOCKSIZE)
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA300
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+endef
+
+define Device/plasmacloud_pa300
+ $(Device/plasmacloud_pa300-common)
+ DEVICE_MODEL := PA300
+endef
+TARGET_DEVICES += plasmacloud_pa300
+
define Device/qihoo_c301
$(Device/seama)
SOC := ar9344