aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2020-12-02 21:31:19 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-04 01:09:32 +0100
commit5b58710fad2137eedad874f0fe8fe22082d1edc6 (patch)
tree2eba497da23bb277362e394cc45b7bc477892204 /target/linux/ath79/image
parentb077accb9c79f215d4da5f44474e72aec07e16dc (diff)
downloadupstream-5b58710fad2137eedad874f0fe8fe22082d1edc6.tar.gz
upstream-5b58710fad2137eedad874f0fe8fe22082d1edc6.tar.bz2
upstream-5b58710fad2137eedad874f0fe8fe22082d1edc6.zip
ath79: add support for D-Link DAP-2680 A1
Specifications: * QCA9558, 16 MiB Flash, 256 MiB RAM, 802.11n 3T3R * QCA9984, 802.11ac Wave 2 3T3R * Gigabit LAN Port (AR8035), 802.11at PoE Installation: * Factory Web UI is at 192.168.0.50 login with 'admin' and blank password, flash factory.bin * Recovery Web UI is at 192.168.0.50 connect network cable, hold reset button during power-on and keep it pressed until uploading has started (only required when checksum is ok, e.g. for reverting back to oem firmware), flash factory.bin After flashing factory.bin, additional free space can be reclaimed by flashing sysupgrade.bin, since the factory image requires some padding to be accepted for upgrading via OEM Web UI. Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 080c6a1603..26ab0fcb34 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -772,6 +772,18 @@ define Device/dlink_dap-2660-a1
endef
TARGET_DEVICES += dlink_dap-2660-a1
+define Device/dlink_dap-2680-a1
+ $(Device/dlink_dap-2xxx)
+ SOC := qca9558
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-2680
+ DEVICE_VARIANT := A1
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct kmod-ath10k-ct
+ IMAGE_SIZE := 15232k
+ DAP_SIGNATURE := wapac36_dkbs_dap2680
+endef
+TARGET_DEVICES += dlink_dap-2680-a1
+
define Device/dlink_dap-2695-a1
SOC := qca9558
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct