aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorPeng Zhang <sd20@qxwlan.com>2020-10-14 15:47:35 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-15 18:52:39 +0200
commit5666ca913a879e499dabb7364fff5e080abe8819 (patch)
treeb188891e5c559f722fc2f3e4b46d26d161a147bb /target/linux/ath79/image
parentdec4a028ab6bdc0235ecda26ac9ad7072caf6b09 (diff)
downloadupstream-5666ca913a879e499dabb7364fff5e080abe8819.tar.gz
upstream-5666ca913a879e499dabb7364fff5e080abe8819.tar.bz2
upstream-5666ca913a879e499dabb7364fff5e080abe8819.zip
ath79: add support for Qxwlan E750A v4
Qxwlan E750A v4 is based on Qualcomm QCA9344. Specification: - 560/450/225 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 8/16 MB of FLASH (SPI NOR) - 2T2R 5G GHz (AR9344) - 2x 10/100 Mbps Ethernet (one port with PoE support) - 1x miniPCIe slot (USB 2.0 bus only) - 7x LED (6 driven by GPIO) - 1x button (reset) - 1x DC jack for main power input (9-48 V) - UART (J23) and LEDs (J2) headers on PCB Flash instruction: 1.Using tftp mode with UART connection and original LEDE image - Configure PC with static IP 192.168.1.10 and tftp server. - Rename "openwrt-ar71xx-generic-xxx-squashfs-sysupgrade.bin" to "firmware.bin" and place it in tftp server directory. - Connect PC with one of LAN ports, power up the router and press key "Enter" to access U-Boot CLI. - Use the following commands to update the device to LEDE: run lfw - After that the device will reboot and boot to LEDE. - Wait until all LEDs stops flashing and use the router. 2.Using httpd mode with Web UI connection and original LEDE image - Configure PC with static IP 192.168.1.xxx(2-255) and tftp server. - Connect PC with one of LAN ports,press the reset button, power up the router and keep button pressed for around 6-7 seconds, until leds flashing. - Open your browser and enter 192.168.1.1,You will see the upgrade interface, select "openwrt-ar71xx-generic-xxx-squashfs- sysupgrade.bin" and click the upgrade button. - After that the device will reboot and boot to LEDE. - Wait until all LEDs stops flashing and use the router. Signed-off-by: Peng Zhang <sd20@qxwlan.com> [cut out of bigger patch, alter use of DEVICE_VARIANT, merge case in 01_leds, use lower case for v4] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c0aacd7ff9..f15d7a3b89 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1475,6 +1475,27 @@ define Device/qihoo_c301
endef
TARGET_DEVICES += qihoo_c301
+define Device/qxwlan_e750a-v4
+ SOC := ar9344
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E750A
+ DEVICE_PACKAGES := kmod-usb2
+endef
+
+define Device/qxwlan_e750a-v4-16m
+ $(Device/qxwlan_e750a-v4)
+ DEVICE_VARIANT := v4 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e750a-v4-16m
+
+define Device/qxwlan_e750a-v4-8m
+ $(Device/qxwlan_e750a-v4)
+ DEVICE_VARIANT := v4 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e750a-v4-8m
+
define Device/rosinson_wr818
SOC := qca9563
DEVICE_VENDOR := Rosinson