aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorJoao Henrique Albuquerque <joaohccalbu@gmail.com>2020-08-14 12:04:02 -0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-05-17 01:01:32 +0200
commit4f07966696134b270e821246c8fd4624c238f1f6 (patch)
tree88e8d93a81ca97f2ecfec3ad2a48a40aa8879d65 /target/linux/ath79/image
parent6ee3680614047f7732731ebbaac946a93ab4f693 (diff)
downloadupstream-4f07966696134b270e821246c8fd4624c238f1f6.tar.gz
upstream-4f07966696134b270e821246c8fd4624c238f1f6.tar.bz2
upstream-4f07966696134b270e821246c8fd4624c238f1f6.zip
ath79: add support for COMFAST CF-E375AC
COMFAST CF-E375AC is a ceiling mount AP with PoE support, based on Qualcomm/Atheros QCA9563 + QCA9886 + QCA8337. Short specification: 2x 10/100/1000 Mbps Ethernet, with PoE support 128MB of RAM (DDR2) 16 MB of FLASH 3T3R 2.4 GHz, 802.11b/g/n 2T2R 5 GHz, 802.11ac/n/a, wave 2 built-in 5x 3 dBi antennas output power (max): 500 mW (27 dBm) 1x RGB LED, 1x button built-in watchdog chipset Flash instruction: 1) Original firmware is based on OpenWrt. Use sysupgrade image directly in vendor GUI. 2) TFTP 2.1) Set a tftp server on your machine with a fixed IP address of 192.168.1.10. A place the sysupgrade as firmware_auto.bin. 2.2) boot the device with an ethernet connection on fixed ip route 2.3) wait a few seconds and try to login via ssh 3) TFTP trough Bootloader 3.1) open the device case and get a uart connection working 3.2) stop the autoboot process and test connection with serverip 3.3) name the sysupgrade image firmware.bin and run firmware_upg MAC addresses: Though the OEM firmware has four adresses in the usual locations, it appears that the assigned addresses are just incremented in a different way: interface address location LAN: *:DC 0x0 WAN *:DD 0x1002 WLAN 2.4g *:E6 n/a (0x0 + 10) WLAN 5g *:DE 0x6 unused *:DF 0x5006 The MAC address pointed at the label is the one assign to the LAN interface. Signed-off-by: Joao Henrique Albuquerque <joaohccalbu@gmail.com> [add label-mac-device, remove redundant uart status, fix whitespace issues, fix commit message wrapping, remove x bit on DTS file] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 222a1511a7..8c21fdc7f0 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -553,6 +553,16 @@ define Device/comfast_cf-e314n-v2
endef
TARGET_DEVICES += comfast_cf-e314n-v2
+define Device/comfast_cf-e375ac
+ SOC := qca9563
+ DEVICE_VENDOR := COMFAST
+ DEVICE_MODEL := CF-E375AC
+ DEVICE_PACKAGES := kmod-ath10k-ct \
+ ath10k-firmware-qca9888-ct -uboot-envtools
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += comfast_cf-e375ac
+
define Device/comfast_cf-e5
SOC := qca9531
DEVICE_VENDOR := COMFAST