aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorDaniel F. Dickinson <cshored@thecshore.com>2018-07-20 16:52:46 -0400
committerJohn Crispin <john@phrozen.org>2018-07-30 10:43:31 +0200
commit4b93cbd17269409b22e4ba9cf5d6f8be86e4fadb (patch)
tree0028b1c2c7346dc6fa63f89787d0ce701a709c7a /target/linux/ath79/image
parent296ae7ab89c179ff39feff973000fcb864754df7 (diff)
downloadupstream-4b93cbd17269409b22e4ba9cf5d6f8be86e4fadb.tar.gz
upstream-4b93cbd17269409b22e4ba9cf5d6f8be86e4fadb.tar.bz2
upstream-4b93cbd17269409b22e4ba9cf5d6f8be86e4fadb.zip
ath79: Port PowerCloud Systems CR5000 support
Add ath79 arch support for PowerCloud Systems CR5000. Previously supported under ar71xx (however there are some errors in that support; to be fixed shortly). Info: * This board is based on the Atheros DB120 reference design, but doesn't use the on-board switch. Instead it attachs GMAC0 to an AR8327 switch. * It only uses GMAC0 and the WAN is simply a VLAN in the stock firmware. * It has 64MB RAM and 8MB flash. * In the dts version we get rid of using 'open-drain' for the AR8327 LED controls. * As with the platform data version we disable JTAG as this conflicts with one of the pair of GPIO's required for the power/status LED (GPIO2 and GPIO4 are used for this LED). * The pcie card wifi has an EEPROM but gets it's MAC address from the ART partition. * The SoC wifi (2.4 GHz) is all from the ART. * The USB is support comes from the SoC. NB. This is actually an AR9342 rather than AR9344 but we use the 9344 definitions because there are no relevant differences for this board. NB: Building only images that don't support reverting to the old cloud-based firmware as the Skydog cloud service for the CR5000 no longer exists. Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fbec180496..d8897784ea 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -66,6 +66,16 @@ define Device/openmesh_om5p-ac-v2
endef
TARGET_DEVICES += openmesh_om5p-ac-v2
+define Device/pcs_cr5000
+ ATH_SOC := ar9344
+ DEVICE_TITLE := PowerCloud Systems CR5000
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport kmod-usb-core
+ IMAGE_SIZE := 7808k
+ IMAGES := sysupgrade.bin
+ SUPPORTED_DEVICES += cr5000
+endef
+TARGET_DEVICES += pcs_cr5000
+
define Device/netgear_wndr3800
ATH_SOC := ar7161
DEVICE_TITLE := NETGEAR WNDR3800